Skip to content

Commit

Permalink
app-metrics/node_exporter: Version bump to 0.16.0_rc2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.30, Repoman-2.3.9
  • Loading branch information
mrueg committed Apr 18, 2018
1 parent 1ee348c commit df87ae3
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-metrics/node_exporter/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST node_exporter-0.15.2.tar.gz 1327204 BLAKE2B ee694771ed6d736fd4bb6a10f713f31becc930fb8225499d4b3a2a2cc7416c1816605cd8f4205dc37a2264af8d9f85e3519bc01844d252b6a70d4ee5f6308ece SHA512 b39ce0801a5bf5a2a70c4034659d047d70b3763af3f18925b65c2b5f72832e261362aaeb9ce4c68cb7bf52e790d3fc710a6c8550ad7876e89fd9f5a055200a52
DIST node_exporter-0.16.0_rc1.tar.gz 1414955 BLAKE2B 6a05e3ca934e59f292133c09f3e6a1d0babaf184f8daa2861fe04192e4fd6d978ea8a7b8530dbe777f81ab762cc7b0899aed39cb7dbd49eae635acd25a957772 SHA512 65a39d15a6645b9a5c5e1650a929229e3ef780fe0d047792f003581322497a6e9ecacfb26af7c22a8d4a7034fd5ce886913e9ec4bfd049d521f01db463573aa8
DIST node_exporter-0.16.0_rc2.tar.gz 1412646 BLAKE2B b73ea3ff38886f88ca64cc1cb137ea2153af93ad5a62c8d409062c23d837c4ee004518782368af45c3d78a8b61ad540f9468256786d75b3d630b27eb250f30cd SHA512 4c4c0c41bc7c91d31fc14e591b9c206a358eddcb0ebf4e057aeb3a2e85486a3b7d4b18e7a9f0e1d27fd1a3ee92e6692f401da2fdd443080962698adca2befc52
48 changes: 48 additions & 0 deletions app-metrics/node_exporter/node_exporter-0.16.0_rc2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit user golang-build golang-vcs-snapshot

EGO_PN="github.com/prometheus/node_exporter"
EGIT_COMMIT="v${PV/_rc/-rc.}"
NODE_EXPORTER_COMMIT="7cbfa88"
ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Prometheus exporter for machine metrics"
HOMEPAGE="https://github.com/prometheus/node_exporter"
SRC_URI="${ARCHIVE_URI}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

DEPEND="dev-util/promu"

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
}

src_prepare() {
default
sed -i -e "s/{{.Revision}}/${NODE_EXPORTER_COMMIT}/" src/${EGO_PN}/.promu.yml || die
}

src_compile() {
pushd src/${EGO_PN} || die
mkdir -p bin || die
GOPATH="${S}" promu build -v --prefix node_exporter || die
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
dobin node_exporter/node_exporter
dodoc {README,CHANGELOG,CONTRIBUTING}.md
popd || die
keepdir /var/lib/node_exporter /var/log/node_exporter
fowners ${PN}:${PN} /var/lib/node_exporter /var/log/node_exporter
newinitd "${FILESDIR}"/${PN}-1.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
}

0 comments on commit df87ae3

Please sign in to comment.