Skip to content

Commit

Permalink
app-portage/eix: Version bump to 0.31.9
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
mrueg committed Aug 31, 2016
1 parent 8b5eb3f commit df8959d
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/eix/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST eix-0.30.11.tar.bz2 790760 SHA256 bea8ddce48fd65d389ee0497baaeb4fa966b9d67f
DIST eix-0.30.4.tar.xz 556632 SHA256 4c753a82e15ce0f8bbdd74edcebb7bc23bd3de8dfca501f86733c335b55d9f4f SHA512 33e62765a9790d18256fcbcb4370b2e63f0b927e3088e0685cbc23dad47e0afa488bb84e5268b4da0d70b5a93b080a866e56257e3df21714ef5fd867f3de182e WHIRLPOOL 5731b6c36f8212fdb4e6b599224699cfc258a1026ef9f8ed8e95618e86df02b5872e7b1f170a3f0698bd348a5084161463d71e6fa14dff859ca92c9b3072dfc2
DIST eix-0.31.7.tar.xz 583100 SHA256 f092c1463a4f49e4b0da97a76b13fd66036a203a590c9ee7cc80e68171d43335 SHA512 cbbdcaa4927e8a6b0b3ea346bc68403eb93d0e386dffec8d9bbd18e48e9c72176b7de00e82132ce12d678d9f775593d42f67a7d9b46230edcb2032d4fbc56832 WHIRLPOOL ee1652c8573f7d6d2fb4565f2f002a8bdfe9abc60c7777b5a6d42a923caaa01fe539cd4d8a505a2db06101c51c295af2dc092bf0bdcb8db7269d61ed49d8531e
DIST eix-0.31.8.tar.xz 585780 SHA256 9c0b6e7eab993609ff8de51fe7f89989e9d9860add238dfc74c92750b5bee7db SHA512 5c42a87047197820e897ab3afc1e76fb4b9edb29863a5cba928c72cd789522767b3306cc04cfb10f264b12740b4cac41121b494847d5e6652fc8ced2eb98d780 WHIRLPOOL 507334be4731bee7b828a0942b44bb05c8936bbffbf48308cb2d3c380b911c02277a62c43805d7d1c28eb9f1a0009f4975593f5416a7dba5a8a37264cf8fd71b
DIST eix-0.31.9.tar.xz 585724 SHA256 2fa324d2ee242bdc686aaf9e33f591379682e115075eb2212c3b885e2c154267 SHA512 9e58f2fdaac05563e2213bef405ee418507794cf30d9390be341e79e525eee35025458456624b33fe241f2dc8c07ab75fc7a04980a9df9f585cc6bb3d1497ad7 WHIRLPOOL a5bebb53b9a77edb281e5b06b8a6813febde7abdaf69c08ca183d579a56b87eee507ccc406c5717ffcffd0af20f7b3a01f58f7248faf258e451d10fa8cbbcffc
72 changes: 72 additions & 0 deletions app-portage/eix/eix-0.31.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PLOCALES="de ru"
inherit bash-completion-r1 l10n systemd

DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
HOMEPAGE="https://github.com/vaeth/eix/"
SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"

BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
nls? ( virtual/libintl )"
RDEPEND="${BOTHDEPEND}
app-shells/push"
DEPEND="${BOTHDEPEND}
app-arch/xz-utils
nls? ( sys-devel/gettext )"

pkg_setup() {
case " ${REPLACING_VERSIONS}" in
*\ 0.[0-9].*|*\ 0.1[0-9].*|*\ 0.2[0-4].*|*\ 0.25.0*)
local eixcache="${EROOT}/var/cache/${PN}"
test -f "${eixcache}" && rm -f -- "${eixcache}";;
esac
}

src_prepare() {
sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
eapply_user
}

src_configure() {
econf $(use_with sqlite) $(use_with doc extra-doc) \
$(use_enable nls) $(use_enable tools separate-tools) \
$(use_enable security) $(use_enable optimization) \
$(use_enable strong-security) \
$(use_enable strong-optimization) $(use_enable debug debugging) \
$(use_enable swap-remote) \
$(use_with prefix always-accept-keywords) \
$(use_with dep dep-default) \
$(use_with required-use required-use-default) \
--with-zsh-completion \
--with-portage-rootpath="${ROOTPATH}" \
--with-eprefix-default="${EPREFIX}"
}

src_install() {
default
dobashcomp bash/eix
systemd_dotmpfilesd tmpfiles.d/eix.conf
}

pkg_postinst() {
test -d "${EROOT}var/cache/${PN}" || {
mkdir "${EROOT}var/cache/${PN}"
use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
}
local obs="${EROOT}var/cache/eix.previous"
! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
}

pkg_postrm() {
[ -n "${REPLACED_BY_VERSION}" ] || rm -rf -- "${EROOT}var/cache/${PN}"
}

0 comments on commit df8959d

Please sign in to comment.