Skip to content

Commit

Permalink
media-libs/harfbuzz: Bump to version 1.8.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.45, Repoman-2.3.10
  • Loading branch information
Lars Wendler committed Aug 9, 2018
1 parent 29899a7 commit dfd8a7f
Show file tree
Hide file tree
Showing 2 changed files with 110 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/harfbuzz/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST harfbuzz-1.7.6.tar.bz2 2586909 BLAKE2B 0ae5902b9fe00a4f05a5dc407d6981959204
DIST harfbuzz-1.8.1.tar.bz2 3804867 BLAKE2B 9687b35bbdb74a42c28764a7b026a46ff90640b84bc40702bdbfadc79bbe3c393de837d4cdbbb8798f28aa8c75687c4f07e1c79e98bf9bd506403d89b4baf6a5 SHA512 7ef27232b294883b0c7404c8412837acfba95f12677f226d764f87e22cd169fe037e7bf13a9309e78c9aa905225fb332b3a143a01b13308b05fcccaeddb0c931
DIST harfbuzz-1.8.5.tar.bz2 3859514 BLAKE2B 6e44de23d81e68ccbe69008f852f5d29fbac8c255808a8330c47d47703035065cf4b48e4d3ce06b50d83d5d3412c3300d0010806b5fed251450d7a7dd0d1395d SHA512 81e4df32d848d52b27413ddf4551bbaa16c04e2cc98f4e2318359b611a725cd55099138106344babcc912a662e6c70354370615452b0d69c38bfa419e063b1a9
DIST harfbuzz-1.8.6.tar.bz2 3864337 BLAKE2B 166425cfec185b23c3d5bb210d88e0b32a9d58c66d38947e0a3366939a5dcd27a047e800b1d1b3cba2597e2034f60efecce5d90f819319e1790e0d4adb793fac SHA512 7412b0f046ef30346358c9321d25fddd98ad44e4cf403f68b77c41b29b9369b5ab9e94164262cea3f487c185786bbdd7813d481896df221f4ab2461d7d43e834
DIST harfbuzz-1.8.7.tar.bz2 3863545 BLAKE2B fac6a6b198fc8cc4d92ae128f9064a3c5ae71ba55891e80cbedd51e91a7df5bd1190f9d51051613a704a3c005b0a8eb850b387ca15b5ff09321ad9df23c70fab SHA512 8654b148fa6fcc34a0e2a981493901a5d93c46934861655c070a228baf136e5ed231cd8a5268948b6ff12ab551870f37d7270d9be649d35d515130540d0eeefa
109 changes: 109 additions & 0 deletions media-libs/harfbuzz/harfbuzz-1.8.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils

DESCRIPTION="An OpenType text shaping engine"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"

if [[ ${PV} = 9999 ]] ; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
inherit git-r3 autotools
else
SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
fi

LICENSE="Old-MIT ISC icu"
SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416

IUSE="+cairo debug fontconfig +glib +graphite icu +introspection static-libs test +truetype"
REQUIRED_USE="introspection? ( glib )"

RDEPEND="
cairo? ( x11-libs/cairo:= )
fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
introspection? ( >=dev-libs/gobject-introspection-1.34:= )
truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
dev-util/gtk-doc-am
virtual/pkgconfig
test? ( ${PYTHON_DEPS} )
"
# eautoreconf requires gobject-introspection-common
# ragel needed if regenerating *.hh files from *.rl
if [[ ${PV} = 9999 ]] ; then
DEPEND+="
>=dev-libs/gobject-introspection-common-1.34
dev-util/ragel
"
fi

pkg_setup() {
use test && python-any-r1_pkg_setup
if ! use debug ; then
append-cppflags -DHB_NDEBUG
fi
}

src_prepare() {
default

xdg_environment_reset

if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
# on Darwin/Solaris we need to link with g++, like automake defaults
# to, but overridden by upstream because on Linux this is not
# necessary, bug #449126
sed -i \
-e 's/\<LINK\>/CXXLINK/' \
src/Makefile.am || die
sed -i \
-e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
src/Makefile.in || die
sed -i \
-e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
test/api/Makefile.in || die
fi

[[ ${PV} == 9999 ]] && eautoreconf
elibtoolize # for Solaris

# bug 618772
append-cxxflags -std=c++14
}

multilib_src_configure() {
# harfbuzz-gobject only used for instrospection, bug #535852
local myeconfargs=(
--without-coretext
--without-uniscribe
$(use_enable static-libs static)
$(multilib_native_use_with cairo)
$(use_with fontconfig)
$(use_with glib)
$(use_with introspection gobject)
$(use_with graphite graphite2)
$(use_with icu)
$(multilib_native_use_enable introspection)
$(use_with truetype freetype)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"

if multilib_is_native_abi; then
ln -s "${S}"/docs/html docs/html || die
fi
}

multilib_src_install_all() {
einstalldocs
find "${ED}" -name "*.la" -delete || die
}

0 comments on commit dfd8a7f

Please sign in to comment.