Skip to content

Commit

Permalink
app-misc/elasticsearch: bump to 7.15.1
Browse files Browse the repository at this point in the history
Signed-off-by: Tomáš Mózes <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
hydrapolic authored and thesamesam committed Nov 11, 2021
1 parent 879158d commit e0508ca
Show file tree
Hide file tree
Showing 2 changed files with 84 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/elasticsearch/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,5 +2,6 @@ DIST elasticsearch-6.8.17.tar.gz 149132823 BLAKE2B a83d4e81059a717e48ac54e7565ef
DIST elasticsearch-6.8.19.tar.gz 149143102 BLAKE2B 74b529d9b9944101c0371c2e1a43697aca0ca5907a4fc25cb7a54b30d9d27a6e876317c8946636314db48ffab59be732ee9a52f2d989c1cff12c11ca91e68cb5 SHA512 2d12a201496668da7547eef77000d2317df083a0d03390549ded9aa80e8ea69d836b62355bb1b8ff363be446887579a34cf417b0b1b8e4d0f6a178598a3cdac1
DIST elasticsearch-7.13.4-no-jdk-linux-x86_64.tar.gz 174690446 BLAKE2B bab17a006f14d262ee85918c8b2e5f610a1e726d158cf423bf306971826f182963e0231456539253f5054069b82672e8803c0da06166215d128bdea02e6738db SHA512 5d6d53d9d6c6faf5d6599019882aa4b5d91f04944ab26c496cab033880b71f1ce2addb98bcf12b21891c005e810ce4a0493627b9ec9f0f78b4f7786efa398eab
DIST elasticsearch-7.15.0-no-jdk-linux-x86_64.tar.gz 196775804 BLAKE2B c08a77a03dd98acbbbdabdf408c33cc7786d8b00e64558b0658e6952d3c32842b2ede48a54e58ee85ece882f56675d77ff39bc2b6ede7d8c7e446bbfd0b23965 SHA512 dbd5c5ce9a08ea0bbc55e9f470a7455d99f1458287cb1d885f07f2670cc8885dbe764315c1267f31ef745a424ece52b4e60239993e0ed7d0bec70dd8c022f7fa
DIST elasticsearch-7.15.1-no-jdk-linux-x86_64.tar.gz 196761964 BLAKE2B a279233f4c7f4f37fbcfe94b0a84d1158bd5d8ca0968e75ae37d752715ba4a6612b50664bc1c7371a6a3894ee1c9ac74ca88ed79a2d1e7c47b3b289565ce21cc SHA512 84690630bc87fe2655f47500f74130e5a72bdc8b0284a7ba914258cb02b16143c221976f5227c4a520e2634cc3da5f1b1ebe311c578ca22b30561a18354746a0
DIST elasticsearch-oss-6.8.17.tar.gz 68247749 BLAKE2B 12e85804a7d58dc27d85fbed6501831d92428405cb4636355c523a370863e00301bd75d7d12404ee0c7eefc32c53bc4b23e8fc1fecf2f606faf85369b2262cc7 SHA512 0f165357b1f389fbd01f07397a2b3ea5d493fae720c15213f2ee47a0c2c75bc4a448384767646d7585a18d4577899b840121c1829a987a16d2de68f216b28f7c
DIST elasticsearch-oss-6.8.19.tar.gz 68255213 BLAKE2B 7fba24a70dafbaf94d2c9f2f25dfc976f831759e8be67ce0a5f15ffe11b9f8d4d62b7906ad5250bcbaacab43139b4471328978c8adc4be527e178597b6bf3294 SHA512 d0a371a4bf19db38b8b0379856a3535c6472e373abd1e9cae0171cffed97005b9fb7b6f7d3d67edc3d67feb5265a9f33d974d6abad8e398148be94566735c2c0
83 changes: 83 additions & 0 deletions app-misc/elasticsearch/elasticsearch-7.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,83 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd tmpfiles

DESCRIPTION="Free and Open, Distributed, RESTful Search Engine"
HOMEPAGE="https://www.elastic.co/elasticsearch/"
SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}-no-jdk-linux-x86_64.tar.gz"
LICENSE="Apache-2.0 BSD-2 Elastic-2.0 LGPL-3 MIT public-domain"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="acct-group/elasticsearch
acct-user/elasticsearch
sys-libs/zlib
virtual/jre"

QA_PREBUILT="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"

src_prepare() {
default

rm LICENSE.txt NOTICE.txt || die
rmdir logs || die
}

src_install() {
keepdir /etc/${PN}
keepdir /etc/${PN}/scripts

insinto /etc/${PN}
doins -r config/.
rm -r config || die

fowners root:${PN} /etc/${PN}
fperms 2750 /etc/${PN}

insinto /usr/share/${PN}
doins -r .

exeinto /usr/share/${PN}/bin
doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"

fperms -R +x /usr/share/${PN}/bin
fperms -R +x /usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin

keepdir /var/{lib,log}/${PN}
fowners ${PN}:${PN} /var/{lib,log}/${PN}
fperms 0750 /var/{lib,log}/${PN}
dodir /usr/share/${PN}/plugins

insinto /etc/sysctl.d
newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf

newconfd "${FILESDIR}/${PN}.conf.4" ${PN}
newinitd "${FILESDIR}/${PN}.init.8" ${PN}

systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service

newtmpfiles "${FILESDIR}"/${PN}.tmpfiles.d ${PN}.conf
}

pkg_postinst() {
tmpfiles_process /usr/lib/tmpfiles.d/${PN}.conf

elog
elog "You may create multiple instances of ${PN} by"
elog "symlinking the init script:"
elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
elog
elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
elog "from /etc/${PN} into the configuration directory of the instance:"
elog "/etc/${PN}/instance"
elog
ewarn "Please make sure you have proper permissions on /etc/${PN}"
ewarn "prior to keystore generation or you may experience startup fails."
ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
}

0 comments on commit e0508ca

Please sign in to comment.