Skip to content

Commit

Permalink
net-dns/dnssec-validator: bump to version 2.2.3
Browse files Browse the repository at this point in the history
The old dnsval package seems to be removed by upstream,
as it has been integrated into the dnssec-tools package.
This version needs support for openssl-1.1.

Closes: https://bugs.gentoo.org/641552
Closes: https://bugs.gentoo.org/672494
Package-Manager: Portage-2.3.60, Repoman-2.3.12
Signed-off-by: Conrad Kostecki <[email protected]>
Closes: gentoo#10597
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
ConiKost authored and mgorny committed Apr 21, 2019
1 parent d2f1a1a commit e14bfd4
Show file tree
Hide file tree
Showing 4 changed files with 117 additions and 4 deletions.
1 change: 1 addition & 0 deletions net-dns/dnssec-validator/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST dnssec-tools-2.2.3.tar.gz 42941393 BLAKE2B b7b6a54113fb5cf030bd60e18f5446b02d1ceba3564ac854b0305225672545e802fecfa1169dc81e68ffe195533e06082dc22500a51b48965aa9c0fc32c915ed SHA512 fd2467f116f77089bddf9311706f356957f4ae735d827d393534e4001b621c9dfc904ff3d4da698d37e8e97b1be9448ab2fd5455c124656399aac30f1f642baf
DIST dnsval-2.2.tar.gz 1060434 BLAKE2B 3a19d5f4128e32f81ae824a128c65b5c5b6f21cef2786d1050631db10084a479614241d869bb33d054d96e7a1e286c472296edf8c4c7e45abd84aaa4df599f28 SHA512 1a01911b08e447d992f4843db8e10bc91041f9e3eaa8a3c050f71f0d7028292145379d1b769e69a837a157443abfa8b0b8ecc289c1b2fa4d33a9234282e9ae05
61 changes: 61 additions & 0 deletions net-dns/dnssec-validator/dnssec-validator-2.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools

DESCRIPTION="Tools to ease the validation of DNSSEC related technologies"
HOMEPAGE="https://www.dnssec-tools.org/"
SRC_URI="https://github.com/DNSSEC-Tools/DNSSEC-Tools/archive/dnssec-tools-${PV}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="dlv +ipv6 +nsec3 static-libs +threads"

RDEPEND=">=dev-libs/openssl-1.1.0:0"
DEPEND="${RDEPEND}"

# Tests fail due "Cannot create context: -7"
RESTRICT="test"

S="${WORKDIR}/DNSSEC-Tools-dnssec-tools-${PV}/dnssec-tools/validator"

PATCHES=(
# Users LDFLAGS are not respected
# See https://github.com/DNSSEC-Tools/DNSSEC-Tools/pull/9
"${FILESDIR}/${P}-ldflags.patch"
)

src_prepare() {
default

mv configure.in configure.ac || die
eautoreconf
}

src_configure() {
local myeconfargs=(
$(use_with dlv)
$(use_with ipv6)
$(use_with nsec3)
$(use_enable static-libs static)
$(use_with threads)
--with-dnsval-conf="${EPREFIX%/}/etc/dnssec-tools/dnsval.conf"
--with-resolv-conf="${EPREFIX%/}/etc/dnssec-tools/resolv.conf"
--with-root-hints="${EPREFIX%/}/etc/dnssec-tools/root.hints"
)

econf "${myeconfargs[@]}"
}

src_install() {
# Install fails with MAKEOPTS > -j1
# See https://github.com/DNSSEC-Tools/DNSSEC-Tools/issues/8
emake -j1 DESTDIR="${D}" install

einstalldocs

find "${D}" -name '*.la' -delete || die
}
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
--- a/libsres/Makefile.in 2018-08-30 00:25:30.000000000 +0200
+++ b/libsres/Makefile.in 2018-12-09 02:32:05.000000000 +0100
@@ -63,7 +63,7 @@
$(RM) -rf $(LT_DIR)

$(LIBRES): $(LOBJ)
- $(LIBTOOLLD) -o $@ $(LOBJ)
+ $(LIBTOOLLD) -o $@ $(LOBJ) $(LDFLAGS)

install:
$(MKPATH) $(DESTDIR)$(libdir)
--- a/libval_shim/Makefile.in 2018-08-30 00:25:30.000000000 +0200
+++ b/libval_shim/Makefile.in 2018-12-09 02:34:56.000000000 +0100
@@ -21,7 +21,7 @@
$(RM) -rf $(LT_DIR)

$(LIBVAL_SHIM): $(LOBJ)
- $(LIBTOOLLD) -o $@ $(LOBJ) $(EXTRA_LIBS)
+ $(LIBTOOLLD) -o $@ $(LOBJ) $(EXTRA_LIBS) $(LDFLAGS)

install:
$(MKPATH) $(DESTDIR)$(libdir)
--- a/libval/Makefile.in 2018-08-30 00:25:30.000000000 +0200
+++ b/libval/Makefile.in 2018-12-09 02:37:32.000000000 +0100
@@ -65,7 +65,7 @@
$(RM) -rf $(LT_DIR)

$(LIBVAL): $(LOBJ)
- $(LIBTOOLLD) -o $@ $(LOBJ) $(LSRES)
+ $(LIBTOOLLD) -o $@ $(LOBJ) $(LSRES) $(LDFLAGS)

install:
$(MKPATH) $(DESTDIR)$(libdir)
26 changes: 22 additions & 4 deletions net-dns/dnssec-validator/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,8 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<use>
<flag name="ecdsa-check">Requires openssl[-bindist]</flag>
</use>
<maintainer type="person">
<email>[email protected]</email>
<name>Conrad Kostecki</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<longdescription>
A tool which can display the sequence of queries and their results
used to validate a DNS query. The stderr output of this command can
serve as input to the drawvalmap tool.
</longdescription>
<use>
<flag name="dlv">Enable support for the DNSSEC look-aside validation</flag>
<flag name="ecdsa-check">Requires openssl[-bindist]</flag>
<flag name="nsec3">Enable support for the NSEC3 Resource Record</flag>
</use>
<upstream>
<bugs-to>https://github.com/dnssec-tools/dnssec-tools/issues</bugs-to>
<remote-id type="github">DNSSEC-Tools/DNSSEC-Tools</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit e14bfd4

Please sign in to comment.