Skip to content

Commit

Permalink
kde-misc/kdeconnect: 1.3.2 version bump
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/666584
Signed-off-by: Andreas Sturmlechner <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
a17r committed Oct 16, 2018
1 parent 3d1ef63 commit e1c8f61
Show file tree
Hide file tree
Showing 2 changed files with 88 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-misc/kdeconnect/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kdeconnect-kde-1.3.1.tar.xz 283636 BLAKE2B 8790ff2f411539db6759ddcad6a9401b2769c7c02f7a0465e0141f10eb6b5675fa56ac89bce94ae02326ce6eb13911f0b97684660df05195df596c1848d1f219 SHA512 52157dc7c7c3caec9871e9feb69c7aa8b82738fa5d4e60bb7492a9ded672351fbb6773ebf166281da9e585798583c1b23ac52bfd60927bb606472b19c5dc8538
DIST kdeconnect-kde-1.3.2.tar.xz 283892 BLAKE2B dcc2b1a4005d21b2165d9b43c78ca68d4109c6ee1ec698cc497f36c0fff482b302fa5c27a2027e58b364c878d1784e508017c36db6057a14d4d0c7a57d775151 SHA512 6ed1a831bf1d6ed8afa875185c54b453c3da9a35f386bfadf494ffe174fc58aa0e3fd1291bd4523bd9c954fc5319527761c249f453f6db879ac46fc185f354ac
87 changes: 87 additions & 0 deletions kde-misc/kdeconnect/kdeconnect-1.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

KDE_HANDBOOK="forceoptional"
KDE_TEST="true"
KMNAME="${PN}-kde"
KDE_SELINUX_MODULE="${PN}"
inherit kde5

if [[ ${KDE_BUILD_TYPE} = release ]]; then
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${KMNAME}-${PV}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Adds communication between KDE Plasma and your smartphone"
HOMEPAGE="https://www.kde.org/ https://community.kde.org/KDEConnect"
LICENSE="GPL-2+"
IUSE="app bluetooth mousepad wayland"

DEPEND="
$(add_frameworks_dep kcmutils)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep knotifications)
$(add_frameworks_dep kservice)
$(add_frameworks_dep kwidgetsaddons)
$(add_qt_dep qtdbus)
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtx11extras)
>=app-crypt/qca-2.1.0:2[qt5(+),ssl]
app? ( $(add_frameworks_dep kdeclarative) )
bluetooth? ( $(add_qt_dep qtbluetooth) )
mousepad? (
x11-libs/libfakekey
x11-libs/libX11
x11-libs/libXtst
)
wayland? ( $(add_frameworks_dep kwayland) )
"
RDEPEND="${DEPEND}
net-fs/sshfs
app? ( $(add_frameworks_dep kirigami) )
wayland? ( $(add_plasma_dep kwin) )
!kde-misc/kdeconnect:4
"

RESTRICT+=" test"

PATCHES=( "${FILESDIR}/${PN}-1.3.0-no-wayland.patch" )

src_prepare() {
kde5_src_prepare

sed \
-e 's#${LIBEXEC_INSTALL_DIR}#@KDE_INSTALL_FULL_LIBEXECDIR@#' \
-i daemon/kdeconnectd.desktop.cmake || die
}

src_configure() {
local mycmakeargs=(
-DEXPERIMENTALAPP_ENABLED=$(usex app)
-DBLUETOOTH_ENABLED=$(usex bluetooth)
$(cmake-utils_use_find_package mousepad LibFakeKey)
$(cmake-utils_use_find_package wayland KF5Wayland)
)

kde5_src_configure
}

pkg_postinst(){
kde5_pkg_postinst

elog "The Android .apk file is available via"
elog "https://play.google.com/store/apps/details?id=org.kde.kdeconnect_tp"
elog "or via"
elog "https://f-droid.org/repository/browse/?fdid=org.kde.kdeconnect_tp"
}

0 comments on commit e1c8f61

Please sign in to comment.