Skip to content

Commit

Permalink
dev-ruby/sprockets-rails: add ruby23 revision
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
graaff committed Jul 18, 2016
1 parent fe7ec0e commit e20b105
Showing 1 changed file with 39 additions and 0 deletions.
39 changes: 39 additions & 0 deletions dev-ruby/sprockets-rails/sprockets-rails-3.0.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22 ruby23"

RUBY_FAKEGEM_TASK_DOC=""

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem versionator

DESCRIPTION="Sprockets implementation for Rails 4.x (and beyond) Asset Pipeline"
HOMEPAGE="https://github.com/rails/sprockets-rails"
SRC_URI="https://github.com/rails/sprockets-rails/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1)"
KEYWORDS="~amd64 ~arm ~amd64-linux"

IUSE="test"

ruby_add_rdepend "
>=dev-ruby/actionpack-4.0:*
>=dev-ruby/activesupport-4.0:*
dev-ruby/sprockets:3"

ruby_add_bdepend "
test? (
>=dev-ruby/actionpack-4
>=dev-ruby/railties-4
dev-ruby/test-unit:2
)"

all_ruby_prepare() {
# Help load correct rack version consistently
sed -i -e "3irequire 'action_controller'" test/test_helper.rb || die
}

0 comments on commit e20b105

Please sign in to comment.