Skip to content

Commit

Permalink
games-util/lutris: Bump to version 0.5.8
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Nov 15, 2020
1 parent ac73470 commit e2769b4
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-util/lutris/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST lutris_0.5.7.1.tar.xz 2145584 BLAKE2B eb766d5e36aca63af7af8f2e85f51b4e3e37b8372b13a59702c545a0c697fa5feb1403cd9589d22c2bdff6593f69ed39e1bcb7ecb28ecc24b7a77b09ed1b2f89 SHA512 9efff4d92ae4d9051a7253324047dfa57f463188ebdbcede5feba2c0268494e8fa7929d2ef30bfe85e52824bbb9c05b1f1688b6658376597cc4cc35c26a19da3
DIST lutris_0.5.7.tar.xz 2133524 BLAKE2B d27191668f582a5cd50941ca227d6121f1bfdb4824c490dd54cc513fda523712af9480451b0e5503404aba8d083c94ce91b928ed3faf4e94ea9f0bbf28b764c1 SHA512 f751be82dd5550dc882932980a3a04a62f183e5f0dddc9939154025408da081392917834324875a80ae8b354906e04835c2df56c23f1d6d29cd9fbdc514e1c57
DIST lutris_0.5.8.tar.xz 892740 BLAKE2B eaa8c71ade35392e701b3fd1d8ef2c0077e7fb7b96c3f037b5e4353d89b50b82e8a75fb2fb537e6ceeb9b6faaa5962e0ffe425f52820168b60eed742024610a4 SHA512 dcd963ff8b3c6d66fe79acc1e1c237196f7351d87bf1b4e5920201ecd7f1b2a80ac59f7151287e70e68c402c2b1b00e961d7314e6d5cbbbae0f4ca5fda562a0f
78 changes: 78 additions & 0 deletions games-util/lutris/lutris-0.5.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"

inherit distutils-r1 virtualx xdg

DESCRIPTION="An open source gaming platform for GNU/Linux"
HOMEPAGE="https://lutris.net/"

if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/lutris/lutris.git"
inherit git-r3
else
SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}"
fi

LICENSE="GPL-3"
SLOT="0"

RESTRICT="!test? ( test )"

BDEPEND="
test? (
$(python_gen_cond_dep '
dev-python/nose[${PYTHON_USEDEP}]
')
)
"
RDEPEND="
app-arch/cabextract
app-arch/p7zip
app-arch/unrar
app-arch/unzip
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
')
gnome-base/gnome-desktop:3[introspection]
media-sound/fluid-soundfont
net-libs/libsoup
net-libs/webkit-gtk:4[introspection]
x11-apps/mesa-progs
x11-apps/xgamma
x11-apps/xrandr
x11-libs/gtk+:3[introspection]
x11-libs/libnotify
"

python_install_all() {
local DOCS=( AUTHORS README.rst docs/installers.rst )
distutils-r1_python_install_all
python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
}

python_test() {
virtx nosetests -v
}

pkg_postinst() {
xdg_pkg_postinst

# Quote README.rst
elog "Lutris installations are fully automated through scripts, which can"
elog "be written in either JSON or YAML. The scripting syntax is described"
elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
elog "available online at lutris.net."
}

0 comments on commit e2769b4

Please sign in to comment.