forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnustep-base/gnustep-base: fix compressed man pages install
Closes: https://bugs.gentoo.org/667276 Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Bernard Cafarelli <[email protected]>
- Loading branch information
Showing
2 changed files
with
100 additions
and
0 deletions.
There are no files selected for viewing
33 changes: 33 additions & 0 deletions
33
gnustep-base/gnustep-base/files/gnustep-base-1.26.0-no_compress_man.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
diff -Naur gnustep-base-1.26.0.orig/Tools/Makefile.postamble gnustep-base-1.26.0/Tools/Makefile.postamble | ||
--- gnustep-base-1.26.0.orig/Tools/Makefile.postamble 2019-01-06 23:33:45.000000000 +0100 | ||
+++ gnustep-base-1.26.0/Tools/Makefile.postamble 2019-04-16 11:20:16.972915636 +0200 | ||
@@ -50,8 +50,6 @@ | ||
for file in $(MAN1_PAGES) __done; do \ | ||
if [ $$file != __done ]; then \ | ||
$(INSTALL_DATA) $$file $(GNUSTEP_DOC_MAN)/man1/$$file; \ | ||
- which gzip && rm -f $(GNUSTEP_DOC_MAN)/man1/$$file.gz \ | ||
- && gzip -9 $(GNUSTEP_DOC_MAN)/man1/$$file; \ | ||
fi; \ | ||
done; \ | ||
if [ ! -f $(GNUSTEP_DOC_MAN)/man8 ]; then \ | ||
@@ -59,8 +57,6 @@ | ||
fi; \ | ||
for file in $(MAN8_PAGES); do \ | ||
$(INSTALL_DATA) $$file $(GNUSTEP_DOC_MAN)/man8/$$file; \ | ||
- which gzip && rm -f $(GNUSTEP_DOC_MAN)/man8/$$file.gz \ | ||
- && gzip -9 $(GNUSTEP_DOC_MAN)/man8/$$file; \ | ||
done$(END_ECHO) | ||
ifeq ($(GNUSTEP_GDOMAP_PORT_OVERRIDE),no) | ||
ifeq ($(GNUSTEP_INSTALL_GDOMAP_AS_SETUID),no) | ||
diff -Naur gnustep-base-1.26.0.orig/Tools/make_strings/GNUmakefile.postamble gnustep-base-1.26.0/Tools/make_strings/GNUmakefile.postamble | ||
--- gnustep-base-1.26.0.orig/Tools/make_strings/GNUmakefile.postamble 2019-01-06 23:33:45.000000000 +0100 | ||
+++ gnustep-base-1.26.0/Tools/make_strings/GNUmakefile.postamble 2019-04-16 11:20:20.756920017 +0200 | ||
@@ -44,8 +44,6 @@ | ||
for file in $(MAN1_PAGES) __done; do \ | ||
if [ $$file != __done ]; then \ | ||
$(INSTALL_DATA) $$file $(GNUSTEP_DOC_MAN)/man1/$$file; \ | ||
- which gzip && rm -f $(GNUSTEP_DOC_MAN)/man1/$$file.gz \ | ||
- && gzip -9 $(GNUSTEP_DOC_MAN)/man1/$$file; \ | ||
fi; \ | ||
done; \ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,67 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit eutils gnustep-base | ||
|
||
DESCRIPTION="A library of general-purpose, non-graphical Objective C objects" | ||
HOMEPAGE="http://www.gnustep.org" | ||
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2 LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris" | ||
IUSE="+gnutls +icu +libffi zeroconf" | ||
|
||
RDEPEND="${GNUSTEP_CORE_DEPEND} | ||
>=gnustep-base/gnustep-make-2.6.0 | ||
gnutls? ( net-libs/gnutls ) | ||
icu? ( >=dev-libs/icu-50.0:= ) | ||
!libffi? ( dev-libs/ffcall | ||
gnustep-base/gnustep-make[-native-exceptions] ) | ||
libffi? ( virtual/libffi ) | ||
>=dev-libs/libxml2-2.6 | ||
>=dev-libs/libxslt-1.1 | ||
>=dev-libs/gmp-4.1:= | ||
>=sys-libs/zlib-1.2 | ||
zeroconf? ( net-dns/avahi )" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
PATCHES=( "${FILESDIR}"/${P}-no_compress_man.patch ) | ||
|
||
src_configure() { | ||
egnustep_env | ||
|
||
local myconf | ||
if use libffi ; then | ||
myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)" | ||
else | ||
myconf="--disable-libffi --enable-ffcall" | ||
fi | ||
|
||
myconf="$myconf $(use_enable gnutls tls)" | ||
myconf="$myconf $(use_enable icu)" | ||
myconf="$myconf $(use_enable zeroconf)" | ||
myconf="$myconf --with-xml-prefix=${EPREFIX}/usr" | ||
myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib" | ||
myconf="$myconf --with-default-config=${EPREFIX}/etc/GNUstep/GNUstep.conf" | ||
|
||
econf $myconf | ||
} | ||
|
||
src_install() { | ||
# We need to set LD_LIBRARY_PATH because the doc generation program | ||
# uses the gnustep-base libraries. Since egnustep_env "cleans the | ||
# environment" including our LD_LIBRARY_PATH, we're left no choice | ||
# but doing it like this. | ||
|
||
egnustep_env | ||
egnustep_install | ||
|
||
if use doc ; then | ||
export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}" | ||
egnustep_doc | ||
fi | ||
egnustep_install_config | ||
} |