Skip to content

Commit

Permalink
app-benchmarks/ltp: Version bump. Do not depend on external libtirpc.…
Browse files Browse the repository at this point in the history
… Bug #552386

Package-Manager: portage-2.2.20.1
  • Loading branch information
Markos Chandras committed Sep 12, 2015
1 parent 73bd238 commit e395ee4
Show file tree
Hide file tree
Showing 3 changed files with 84 additions and 2 deletions.
1 change: 1 addition & 0 deletions app-benchmarks/ltp/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST ltp-20130503.tar.gz 4698775 SHA256 34519b6365cae24f8d8bb8a4ec0955d83999b1a4
DIST ltp-20140828.tar.gz 4690629 SHA256 95febd3db2c33d74b180c532f8bf9a9bac3ce27e2603aee28cad15f85834cde9 SHA512 e685f109d0e74bfd2bcd7604c744872967d3a6d34d5fa8ee87867501da1162b27777f0c3c099836d9d14b2eab319bad6da87cb2e3fabec478cf95b692b4e2fe8 WHIRLPOOL 5cff0a5ef887135f8b1baa4f10df54f5422a22f71a5d417b1c25f0c2b8c9e40d238d743216e2128b6f30ab97b1949df168320198e991a20c455e3c669efb626b
DIST ltp-20150119.tar.gz 4695541 SHA256 6cba3476e5bef74d21979c45d0629632bfaeaafc4dbbebccd187ba7b6b9dca52 SHA512 5e5624738da08a3f5f5b08d821a73666d6ef9957b62ff72bd12aba0d021c304dae5652956a6af60aa593256cadd98f061759d5a65045ff5b1864956ea5ad5186 WHIRLPOOL 0417bf1c41347aca68b9e9fb3b203c209f36112ecdf7f020d32060ac637949b1cf40e437f976352ebca1d4566394abe2149b14ad946e1fa2f37cf68397c3e610
DIST ltp-20150420.tar.gz 4673384 SHA256 65a6ed64d55edc77f0ff690e269dc3ef32290d4499ccbb8f24b2cf59dd974408 SHA512 a5d259cf2a984eae1a0e6b7be538f06eb6021e0f961bb7683aaafc1bad347e73690fa5d6ae39beb6c92c9ea69e4160841d0e46ac49ccfa77053f1c7a0a854099 WHIRLPOOL 7d0b26c8a1f99cea1a609545671d6160278cf81c4654fff7dba84688e37b6f6349e3a2b90cb44ef7abf5c7cfad2187543431df23dd5833917f8b446db8425aec
DIST ltp-20150903.tar.gz 4680969 SHA256 e670ae9f1e42bc8b500edd3c3a5cf09c6447c56d7738a22235c87a13739bcace SHA512 9d52e1f82e2052ec4ed8dde9e246fd1b9dc1b665110e7a20f11de741d41f024e85443571846efe3181592e7bf3b63ed88e9ae9878c5c6f4f759171b245948ef2 WHIRLPOOL 0665affbb226ccf26028818220c41d965c20e2bf257347f01ac6e90f6f8d6f579c4fb1a0d3154d3773b4189787c7e0d99cc6b06f873cff2b6c44a0c1de777d0c
5 changes: 3 additions & 2 deletions app-benchmarks/ltp/ltp-20150420.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -50,8 +50,9 @@ src_configure() {

# Better put it into /opt/${PN} as everything needs to
# be under the same directory..

econf --prefix=/opt/${PN} ${myconf}
# Avoid depending on external libtirpc (#552386)
ac_cv_lib_tirpc_rpcb_set=no \
econf --prefix=/opt/${PN} ${myconf}
}

src_compile() {
Expand Down
80 changes: 80 additions & 0 deletions app-benchmarks/ltp/ltp-20150903.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit autotools eutils readme.gentoo

DESCRIPTION="A testsuite for the linux kernel"
HOMEPAGE="http://linux-test-project.github.io/"
SRC_URI="https://github.com/linux-test-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"

KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE="expect perl pm open-posix python rt"

DEPEND="expect? ( dev-tcltk/expect )
perl? ( dev-lang/perl )
python? ( dev-lang/python )"

RESTRICT="test"

pkg_setup() {
# Don't create groups
export CREATE=0

DOC_CONTENTS="LTP requires root access to run the tests.
The LTP root directory is located in /opt/${PN}.
For more information please read the ltp-howto located in
/usr/share/doc/${PF}"
}

src_prepare() {
# regenerate
AT_M4DIR="m4" eautoreconf
}

src_configure() {
# FIXME: improve me
local myconf=
use open-posix && myconf+="--with-open-posix-testsuite "
use pm && mytconf+="--with-power-management-testsuite "
use rt && myconf+="--with-realtime-testsuite "
use perl && myconf+="--with-perl "
use python && myconf+="--with-python "
use expect && myconf+="--with-expect "
# Prevent any kernel stuff for now as it leads to sandbox violations
myconf+="--without-modules --with-linux-dir=/dev/null"

# Better put it into /opt/${PN} as everything needs to
# be under the same directory..
# Avoid depending on external libtirpc (#552386)
ac_cv_lib_tirpc_rpcb_set=no \
econf --prefix=/opt/${PN} ${myconf}
}

src_compile() {
# Posix testsuite does not seem to build with -j>1
# Is this maintained anymore?
if use open-posix; then
export MAKEOPTS="-j1"
fi
emake
}

src_install() {
default
dosym /usr/libexec/${PN}/runltp /usr/bin/runltp
# install docs
dodoc doc/MaintNotes
for txt in doc/*.txt; do
dodoc ${txt}
done
dodoc -r doc/testcases
dohtml -r doc/automation-*.html
doman doc/man1/*.1
doman doc/man3/*.3
readme.gentoo_create_doc
}

0 comments on commit e395ee4

Please sign in to comment.