Skip to content

Commit

Permalink
app-office/lyx: 2.3.0 version bump
Browse files Browse the repository at this point in the history
Thanks-to: pavel sanda <[email protected]>
Bug: https://bugs.gentoo.org/631798
Package-Manager: Portage-2.3.27, Repoman-2.3.9
  • Loading branch information
a17r committed Mar 30, 2018
1 parent c78931b commit e3a198c
Show file tree
Hide file tree
Showing 3 changed files with 208 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/lyx/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lyx-2.2.3.tar.xz 15501856 BLAKE2B 08606f0c18d9cb5891bd7d612361597e3efc7e7855f7607c2620f10ddb22b7078d5085f725911496198d2d8a47ece54cbfe67cfbf4ec8eb15450271cd133b095 SHA512 b5a4a16b22680022651a0f3911c2c24bcd3541a573e672e541cb0af6572089e4b0e0ec1cafb40850e75c377e7da5b286d0314886e0c57d55f57645d8e4a07708
DIST lyx-2.3.0.tar.xz 15676680 BLAKE2B 4b09f4c3979f51a8b30825c07fe3b24f080bfc8f42d54e94809e342087b683ca24edcb835994583b28d5b9c13868736f850d6c88b229e2d7f6f6bc0fd64c722c SHA512 77366d365f600069564b6d508ba2169744bbc7bc4dc9cb7e9d5f44941796dd7a027ca9ad08f5a67fd6863cbd1f6308ce5233b6e8685ebc6cf78ed19eef84ccb5
30 changes: 30 additions & 0 deletions app-office/lyx/files/lyx-2.3.0-python.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
diff --git a/src/graphics/GraphicsConverter.cpp b/src/graphics/GraphicsConverter.cpp
index 97c4f68..8f05e62 100644
--- a/src/graphics/GraphicsConverter.cpp
+++ b/src/graphics/GraphicsConverter.cpp
@@ -262,7 +262,7 @@ static void build_script(FileName const & from_file,
LYXERR(Debug::GRAPHICS, "build_script ... ");
typedef Graph::EdgePath EdgePath;

- script << "#!/usr/bin/env python\n"
+ script << "#!/usr/bin/env python2\n"
"# -*- coding: utf-8 -*-\n"
"import os, shutil, sys\n\n"
"def unlinkNoThrow(file):\n"
diff --git a/src/support/os.cpp b/src/support/os.cpp
index 8eea49370a..d7a0f81aa3 100644
--- a/src/support/os.cpp
+++ b/src/support/os.cpp
@@ -65,10 +65,10 @@ int timeout_min()
string const python(bool reset)
{
// Check whether the first python in PATH is the right one.
- static string command = python23("python -tt");
+ static string command = python23("python2 -tt");
// FIXME THREAD
if (reset) {
- command = python23("python -tt");
+ command = python23("python2 -tt");
}

if (command.empty()) {
177 changes: 177 additions & 0 deletions app-office/lyx/lyx-2.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,177 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )
inherit gnome2-utils xdg-utils flag-o-matic font python-single-r1 qmake-utils toolchain-funcs multilib desktop

MY_P="${P/_}"

S="${WORKDIR}/${MY_P}"
FONT_S="${S}/lib/fonts"
FONT_SUFFIX="ttf"
DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
HOMEPAGE="https://www.lyx.org/"
SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.3.x/${MY_P}.tar.xz
ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.3/${MY_P}/${MY_P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
IUSE="aspell cups debug docbook dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf subversion svg l10n_he"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
dev-libs/boost:=
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
dev-texlive/texlive-fontsextra
sys-apps/file
sys-libs/zlib
virtual/imagemagick-tools[png,svg?]
aspell? ( app-text/aspell )
cups? ( net-print/cups )
dia? ( app-office/dia )
docbook? ( app-text/sgmltools-lite )
dot? ( media-gfx/graphviz )
enchant? ( app-text/enchant )
gnumeric? ( app-office/gnumeric )
html? ( dev-tex/html2latex )
hunspell? ( app-text/hunspell )
l10n_he? ( dev-tex/culmus-latex )
latex? (
app-text/dvipng
app-text/ghostscript-gpl
app-text/ps2eps
app-text/texlive
dev-tex/chktex
dev-tex/dvipost
dev-texlive/texlive-fontsrecommended
dev-texlive/texlive-latexextra
dev-texlive/texlive-pictures
|| ( dev-texlive/texlive-mathscience dev-texlive/texlive-science )
|| ( dev-texlive/texlive-plaingeneric dev-texlive/texlive-genericextra )
|| (
dev-tex/hevea
dev-tex/latex2html
dev-tex/tex4ht[java]
dev-tex/tth
)
)
rcs? ( dev-vcs/rcs )
rtf? (
app-text/unrtf
dev-tex/html2latex
dev-tex/latex2rtf
)
subversion? ( dev-vcs/subversion )
svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
dev-qt/qtconcurrent:5
nls? ( sys-devel/gettext )
"

DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )

PATCHES=( "${FILESDIR}"/${P}-python.patch )

pkg_setup() {
python-single-r1_pkg_setup
font_pkg_setup
}

src_prepare() {
default
sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
}

src_configure() {
tc-export CXX
#bug 221921
export VARTEXFONTS=${T}/fonts

econf \
$(use_with aspell) \
$(use_enable debug) \
$(use_with enchant) \
$(use_with hunspell) \
$(use_enable monolithic-build) \
$(use_enable nls) \
--enable-qt5 \
--with-qt-dir=$(qt5_get_libdir)/qt5 \
--disable-stdlib-debug \
--without-included-boost \
--with-packaging=posix
}

src_install() {
default

if use l10n_he ; then
echo "\bind_file cua" > "${T}"/hebrew.bind
echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind

insinto /usr/share/lyx/bind
doins "${T}"/hebrew.bind
fi

newicon -s 32 "${S}/development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
doicon -s 48 "${S}/lib/images/lyx.png"
doicon -s scalable "${S}/lib/images/lyx.svg"

# fix for bug 91108
if use latex ; then
dosym ../../../lyx/tex /usr/share/texmf-site/tex/latex/lyx
fi

# fonts needed for proper math display, see also bug #15629
font_src_install

python_fix_shebang "${ED}"/usr/share/${PN}

if use hunspell ; then
dosym ../myspell /usr/share/lyx/dicts
dosym ../myspell /usr/share/lyx/thes
fi
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
font_pkg_postinst
gnome2_icon_cache_update
xdg_desktop_database_update

# fix for bug 91108
if use latex ; then
texhash
fi

# instructions for RTL support. See also bug 168331.
if use l10n_he || has he ${LINGUAS} || has ar ${LINGUAS} ; then
elog
elog "Enabling RTL support in LyX:"
elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
elog "You must enable RTL support in LyX. To do so start LyX and go to"
elog "Tools->Preferences->Language settings->Language"
elog "and make sure the \"Right-to-left language support\" is checked"
elog
fi
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update

if use latex ; then
texhash
fi
}

0 comments on commit e3a198c

Please sign in to comment.