Skip to content

Commit

Permalink
app-vim/vimoutliner: Add missing PYTHON_DEPS
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jul 22, 2019
1 parent 29ad6fa commit e419e96
Show file tree
Hide file tree
Showing 4 changed files with 56 additions and 54 deletions.
31 changes: 3 additions & 28 deletions app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,48 +1,23 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_5,3_6} )

inherit vim-plugin python-single-r1
inherit vim-plugin

DESCRIPTION="vim plugin: easy and fast outlining"
HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"
KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"

VIM_PLUGIN_HELPFILES="vimoutliner"
VIM_PLUGIN_MESSAGES="filetype"

PATCHES=( "${FILESDIR}/${P}-fix-shebangs.patch" )

RDEPEND="dev-python/autopep8"

pkg_setup() {
python-single-r1_pkg_setup
}

src_prepare() {
default
sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
sed -i -e 's/g:vo_modules2load/g:vo_modules_load/' vimoutliner/vimoutlinerrc || die
rm -v install.sh || die
find "${S}" -type f -exec chmod a+r {} \; || die
}

src_compile() {
local pyscript _pyscript
for pyscript in $(find "${S}" -type f -name \*.py); do
_pyscript=$(basename "${pyscript}")
einfo "Processing ${_pyscript}"
sed -i -e 's#[ \t]*$##g;' "${pyscript}" || die
2to3 --no-diffs -w -n "${pyscript}" 2> /dev/null || die
autopep8 -i "${pyscript}" || die
python_fix_shebang -q "${pyscript}" || die
eend $?
done
}
49 changes: 49 additions & 0 deletions app-vim/vimoutliner/vimoutliner-0.3.6-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_5,3_6} )

inherit vim-plugin python-single-r1

DESCRIPTION="vim plugin: easy and fast outlining"
HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

VIM_PLUGIN_HELPFILES="vimoutliner"
VIM_PLUGIN_MESSAGES="filetype"

PATCHES=( "${FILESDIR}/${P}-fix-shebangs.patch" )

RDEPEND="${PYTHON_DEPS}
dev-python/autopep8[${PYTHON_USEDEP}]"

pkg_setup() {
python-single-r1_pkg_setup
}

src_prepare() {
default
sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
sed -i -e 's/g:vo_modules2load/g:vo_modules_load/' vimoutliner/vimoutlinerrc || die
rm -v install.sh || die
find "${S}" -type f -exec chmod a+r {} \; || die
}

src_compile() {
local pyscript _pyscript
for pyscript in $(find "${S}" -type f -name \*.py); do
_pyscript=$(basename "${pyscript}")
einfo "Processing ${_pyscript}"
sed -i -e 's#[ \t]*$##g;' "${pyscript}" || die
2to3 --no-diffs -w -n "${pyscript}" 2> /dev/null || die
autopep8 -i "${pyscript}" || die
python_fix_shebang -q "${pyscript}" || die
eend $?
done
}
23 changes: 0 additions & 23 deletions app-vim/vimoutliner/vimoutliner-0.3.6.ebuild

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -22,13 +22,14 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
VIM_PLUGIN_HELPFILES="vimoutliner"
VIM_PLUGIN_MESSAGES="filetype"

RDEPEND="dev-python/autopep8"
RDEPEND="${PYTHON_DEPS}
dev-python/autopep8[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"

src_prepare() {
default

sed -i -e '1s:^:#!/usr/bin/python\n:' vimoutliner/scripts/otl2latex/otl2latex.py
sed -i -e '1s:^:#!/usr/bin/python\n:' vimoutliner/scripts/otl2latex/otl2latex.py || die
find "${S}" -type f -exec chmod a+r {} \; || die
}

Expand Down

0 comments on commit e419e96

Please sign in to comment.