Skip to content

Commit

Permalink
dev-python/PyQt5: add 5.13.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Davide Pesavento <[email protected]>
  • Loading branch information
Pesa committed Jul 10, 2019
1 parent cdde23b commit e4335b9
Show file tree
Hide file tree
Showing 2 changed files with 201 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/PyQt5/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST PyQt5_gpl-5.10.1.tar.gz 3110469 BLAKE2B 75e24bd8c0739d47eff6212435aa783eaa302633beb0494f099edc3f8f99600cd03dc3cba5152ed7ae703cfe445ecae06ec5d2281dd7c0640c71db041659bd6f SHA512 04cd0292f7a088f9c0d088d7c73ec96cfc40253f771dfdf194eb92be7635e6fcaf04863fa24215e9c34a096658549bb2feeb8d8fdca1e39ed87f0256ef0f790b
DIST PyQt5_gpl-5.12.2.tar.gz 3147205 BLAKE2B ad0b09548521ceff869bb44cfceb0c2cf31338f46c76da23582f7949fdcc0e8feee3cc0dc0610e8152dfbc701c3ac765eea7898f5061775a92e2601c5b7ea8ca SHA512 dc23bb7dacb305d4f9a630f2b5c3809d5d6734ba234c9941a3c44c770af8534dd737160dbe007a1f15d5c90e2e52419dd749b3ef942b4e71917c1cea2220a666
DIST PyQt5_gpl-5.13.0.tar.gz 3152704 BLAKE2B caa9b11f70b656a23d28f4b7b490df544e82f669e38e51e87316917f015f9cf137a0902333323cfc5c6a13bf446067d5714fb33c091efdce03a0f7cfa8771a15 SHA512 72cdd700956f8a5791fd38cac6a348f189eec9e69f3fd79a0c711ff49c770d4982fe62ec9057830d26abc4c12133922df915be0844449212f0bdf338fe1e4cb0
200 changes: 200 additions & 0 deletions dev-python/PyQt5/PyQt5-5.13.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,200 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit multibuild python-r1 qmake-utils

DESCRIPTION="Python bindings for the Qt framework"
HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/intro"

MY_PN=PyQt5
MY_P=${MY_PN}_gpl-${PV/_pre/.dev}
if [[ ${PV} == *_pre* ]]; then
SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
else
SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
fi

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"

# TODO: QtNfc, QtRemoteObjects (Qt >= 5.12)
IUSE="bluetooth dbus debug declarative designer examples gles2 gui help location multimedia
network networkauth opengl positioning printsupport sensors serialport sql +ssl svg
testlib webchannel webkit websockets widgets x11extras xmlpatterns"

# The requirements below were extracted from configure.py
# and from the output of 'grep -r "%Import " "${S}"/sip'
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
bluetooth? ( gui )
declarative? ( gui network )
designer? ( widgets )
help? ( gui widgets )
location? ( positioning )
multimedia? ( gui network )
networkauth? ( network )
opengl? ( gui widgets )
positioning? ( gui )
printsupport? ( gui widgets )
sensors? ( gui )
serialport? ( gui )
sql? ( widgets )
svg? ( gui widgets )
testlib? ( widgets )
webchannel? ( network )
webkit? ( gui network printsupport widgets )
websockets? ( network )
widgets? ( gui )
xmlpatterns? ( network )
"

# Minimal supported version of Qt.
QT_PV="5.10:5"

RDEPEND="
${PYTHON_DEPS}
>=dev-python/PyQt5-sip-4.19.14:=[${PYTHON_USEDEP}]
>=dev-qt/qtcore-${QT_PV}
>=dev-qt/qtxml-${QT_PV}
virtual/python-enum34[${PYTHON_USEDEP}]
bluetooth? ( >=dev-qt/qtbluetooth-${QT_PV} )
dbus? (
dev-python/dbus-python[${PYTHON_USEDEP}]
>=dev-qt/qtdbus-${QT_PV}
)
declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
designer? ( >=dev-qt/designer-${QT_PV} )
gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
help? ( >=dev-qt/qthelp-${QT_PV} )
location? ( >=dev-qt/qtlocation-${QT_PV} )
multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
network? ( >=dev-qt/qtnetwork-${QT_PV}[ssl=] )
networkauth? ( >=dev-qt/qtnetworkauth-${QT_PV} )
opengl? ( >=dev-qt/qtopengl-${QT_PV} )
positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
sensors? ( >=dev-qt/qtsensors-${QT_PV} )
serialport? ( >=dev-qt/qtserialport-${QT_PV} )
sql? ( >=dev-qt/qtsql-${QT_PV} )
svg? ( >=dev-qt/qtsvg-${QT_PV} )
testlib? ( >=dev-qt/qttest-${QT_PV} )
webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
webkit? ( dev-qt/qtwebkit:5[printsupport] )
websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
"
DEPEND="${RDEPEND}
>=dev-python/sip-4.19.14[${PYTHON_USEDEP}]
dbus? ( virtual/pkgconfig )
"

S=${WORKDIR}/${MY_P}

pyqt_use_enable() {
use "$1" || return

if [[ $# -eq 1 ]]; then
echo --enable=Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}
else
shift
echo ${@/#/--enable=}
fi
}

src_configure() {
configuration() {
local myconf=(
"${PYTHON}"
"${S}"/configure.py
$(usex debug '--debug --qml-debug --trace' '')
--verbose
--confirm-license
--qmake="$(qt5_get_bindir)"/qmake
--bindir="${EPREFIX}/usr/bin"
--qsci-api
--enable=QtCore
--enable=QtXml
$(pyqt_use_enable bluetooth)
$(pyqt_use_enable dbus QtDBus)
$(usex dbus '' --no-python-dbus)
$(pyqt_use_enable declarative QtQml QtQuick $(usex widgets QtQuickWidgets ''))
$(usex declarative '' --no-qml-plugin)
$(pyqt_use_enable designer)
$(usex designer '' --no-designer-plugin)
$(usex gles2 '--disable-feature=PyQt_Desktop_OpenGL' '')
$(pyqt_use_enable gui)
$(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
$(pyqt_use_enable help)
$(pyqt_use_enable location)
$(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
$(pyqt_use_enable network)
$(pyqt_use_enable networkauth QtNetworkAuth)
$(pyqt_use_enable opengl QtOpenGL)
$(pyqt_use_enable positioning)
$(pyqt_use_enable printsupport QtPrintSupport)
$(pyqt_use_enable sensors)
$(pyqt_use_enable serialport QtSerialPort)
$(pyqt_use_enable sql)
$(usex ssl '' '--disable-feature=PyQt_SSL')
$(pyqt_use_enable svg)
$(pyqt_use_enable testlib QtTest)
$(pyqt_use_enable webchannel QtWebChannel)
$(pyqt_use_enable webkit QtWebKit QtWebKitWidgets)
$(pyqt_use_enable websockets QtWebSockets)
$(pyqt_use_enable widgets)
$(pyqt_use_enable x11extras QtX11Extras)
$(pyqt_use_enable xmlpatterns QtXmlPatterns)
)
echo "${myconf[@]}"
"${myconf[@]}" || die

# Fix parallel install failure
sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets' ${MY_PN}.pro || die

# Run eqmake to respect toolchain and build flags
eqmake5 -recursive ${MY_PN}.pro
}
python_foreach_impl run_in_build_dir configuration
}

src_compile() {
python_foreach_impl run_in_build_dir default
}

src_install() {
installation() {
local tmp_root=${D}/${MY_PN}_tmp_root
emake INSTALL_ROOT="${tmp_root}" install

local bin_dir=${tmp_root}${EPREFIX}/usr/bin
local exe
for exe in pylupdate5 pyrcc5 pyuic5; do
python_doexe "${bin_dir}/${exe}"
rm "${bin_dir}/${exe}" || die
done

local uic_dir=${tmp_root}$(python_get_sitedir)/${MY_PN}/uic
if python_is_python3; then
rm -r "${uic_dir}"/port_v2 || die
else
rm -r "${uic_dir}"/port_v3 || die
fi

multibuild_merge_root "${tmp_root}" "${D}"
python_optimize
}
python_foreach_impl run_in_build_dir installation

einstalldocs

if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples
fi
}

0 comments on commit e4335b9

Please sign in to comment.