Skip to content

Commit

Permalink
dev-cpp/libjson-rpc-cpp: Switch to dev-cpp/catch-2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 3, 2018
1 parent ae5512f commit e45d5c1
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 2 deletions.
67 changes: 67 additions & 0 deletions dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-1.1.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="JSON-RPC (1.0 & 2.0) framework for C++"
HOMEPAGE="https://github.com/cinemast/libjson-rpc-cpp"
SRC_URI="https://github.com/cinemast/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0/1"
KEYWORDS="~amd64 ~x86"
IUSE="doc +http-client +http-server redis-client redis-server +stubgen test"

RDEPEND="
dev-libs/jsoncpp:=
http-client? ( net-misc/curl:= )
http-server? ( net-libs/libmicrohttpd:= )
redis-client? ( dev-libs/hiredis:= )
redis-server? ( dev-libs/hiredis:= )
stubgen? ( dev-libs/argtable:= )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
test? ( >=dev-cpp/catch-2 )"

RESTRICT="!test? ( test )"

src_configure() {
local mycmakeargs=(
-DHTTP_CLIENT=$(usex http-client)
-DHTTP_SERVER=$(usex http-server)
-DREDIS_CLIENT=$(usex redis-client)
-DREDIS_SERVER=$(usex redis-server)
# they have no deps
-DTCP_SOCKET_CLIENT=ON
-DTCP_SOCKET_SERVER=ON
-DUNIX_DOMAIN_SOCKET_CLIENT=ON
-DUNIX_DOMAIN_SOCKET_SERVER=ON
# they are not installed
-DCOMPILE_EXAMPLES=OFF
-DCOMPILE_STUBGEN=$(usex stubgen)
-DCOMPILE_TESTS=$(usex test)
-DCATCH_INCLUDE_DIR="${EPREFIX}/usr/include/catch2"
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile

use doc && emake -C "${BUILD_DIR}" doc
}

src_test() {
# Tests fail randomly when run in parallel
local MAKEOPTS=-j1
cmake-utils_src_test
}

src_install() {
cmake-utils_src_install

use doc && dodoc -r "${BUILD_DIR}"/doc/html
}
4 changes: 2 additions & 2 deletions dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ RDEPEND="
stubgen? ( dev-libs/argtable:= )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
test? ( <dev-cpp/catch-2 )"
test? ( >=dev-cpp/catch-2 )"

RESTRICT="!test? ( test )"

Expand All @@ -44,7 +44,7 @@ src_configure() {
-DCOMPILE_EXAMPLES=OFF
-DCOMPILE_STUBGEN=$(usex stubgen)
-DCOMPILE_TESTS=$(usex test)
-DCATCH_INCLUDE_DIR="${EPREFIX}/usr/include/catch"
-DCATCH_INCLUDE_DIR="${EPREFIX}/usr/include/catch2"
)

cmake-utils_src_configure
Expand Down

0 comments on commit e45d5c1

Please sign in to comment.