Skip to content

Commit

Permalink
media-libs/alsa-lib: Bump to version 1.1.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Nov 15, 2017
1 parent ba2c466 commit e4654f2
Show file tree
Hide file tree
Showing 2 changed files with 91 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/alsa-lib/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST alsa-lib-1.1.2.tar.bz2 947423 SHA256 d38dacd9892b06b8bff04923c380b38fb2e379
DIST alsa-lib-1.1.3.tar.bz2 962001 SHA256 71282502184c592c1a008e256c22ed0ba5728ca65e05273ceb480c70f515969c SHA512 f5dbe2375a8c66af14378314a5238284d4ed63dfc86a750c0c6e8f6cdb6b1ea2d8ef26f870b5d152dc0b77d9b40821cab523f6734902b91583beb08e28c66850 WHIRLPOOL f33871789a7cc06a9db83fd659abdfeb7940d61a24ad7c71866f843d8c0c29eaf0e0770a2034dee2526c96835935b88c2fe882184c86528c98e7d4901f94b27d
DIST alsa-lib-1.1.4.1.tar.bz2 974584 SHA256 91bb870c14d1c7c269213285eeed874fa3d28112077db061a3af8010d0885b76 SHA512 7b548c4ee29c4a1230a0edcd5d19219831290f96a214180a6530628acc05278d1348376195287d188f4f44d6be1914391c63994f1b50985c3eee74352da26b0b WHIRLPOOL 2fc84b8a3c6023dac7953f1d2960a8eb5279f58cf2e59b8f5d04293df7595b9f0ebca5738bf4a333f8b20586c7fd579b9e7bdeeffd64518649be3a8c5d588fd8
DIST alsa-lib-1.1.4.tar.bz2 973825 SHA256 82f50a09487079755d93e4c9384912196995bade6280bce9bfdcabf094bfb515 SHA512 8dfc5cc8872138b9e7e234934e317d797e100ac99dac86a2a2e4bdcc0d49e8a05b4089b98341051b407750bed93c2713fae5218318e5ce6cc7db2801165a1c10 WHIRLPOOL 74eb6742d93b6f2988ea9f583623edd985897db278e5dcac6916b3e9b772f16db326feb37b81a191405cc43ec2a55d313e74293ccbb43281b15f3056bd8f623f
DIST alsa-lib-1.1.5.tar.bz2 979225 SHA256 f4f68ad3c6da36b0b5241ac3c798a7a71e0e97d51f972e9f723b3f20a9650ae6 SHA512 c79ceaa1ebfeda2caf41a0495ea31dd2748a11795989aebc341ae13a5c96d21495e4542571d5590e68b2575ceddd6e84059a950ddb78e6c0b9d94861faee4f58 WHIRLPOOL 7b327499e8576c07e4ed7fe293f788283e158f08efd10ad5b7ca9f980cbe5dcd9fcc290a9880726a971bd180f5a0c57215d5f337e5294ace25fe5923ea6fbcbd
90 changes: 90 additions & 0 deletions media-libs/alsa-lib/alsa-lib-1.1.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,90 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

# no support for python3_2 or above yet wrt #471326
PYTHON_COMPAT=( python2_7 )

inherit autotools eutils multilib multilib-minimal python-single-r1

DESCRIPTION="Advanced Linux Sound Architecture Library"
HOMEPAGE="http://www.alsa-project.org/"
SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="alisp debug doc elibc_uclibc python"

RDEPEND="python? ( ${PYTHON_DEPS} )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-soundlibs-20130224-r1
!app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
)"
DEPEND="${RDEPEND}
doc? ( >=app-doc/doxygen-1.2.6 )"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
# https://bugs.gentoo.org/509886
use elibc_uclibc && { sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die; }
# https://bugs.gentoo.org/545950
sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
default
eautoreconf
}

multilib_src_configure() {
local myconf
# enable Python only on final ABI
if multilib_is_native_abi; then
myconf="$(use_enable python)"
else
myconf="--disable-python"
fi
use elibc_uclibc && myconf+=" --without-versioned"

ECONF_SOURCE=${S} \
econf \
--disable-maintainer-mode \
--enable-shared \
--disable-resmgr \
--enable-rawmidi \
--enable-seq \
--enable-aload \
$(use_with debug) \
$(use_enable alisp) \
${myconf}
}

multilib_src_compile() {
emake

if multilib_is_native_abi && use doc; then
emake doc
fgrep -Zrl "${S}" doc/doxygen/html | \
xargs -0 sed -i -e "s:${S}::"
fi
}

multilib_src_install() {
emake DESTDIR="${D}" install
if multilib_is_native_abi && use doc; then
docinto html
dodoc -r doc/doxygen/html/.
fi
}

multilib_src_install_all() {
prune_libtool_files --all
find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
docinto ""
dodoc ChangeLog doc/asoundrc.txt NOTES TODO
}

0 comments on commit e4654f2

Please sign in to comment.