Skip to content

Commit

Permalink
app-text/sigil: bump v1.2.1
Browse files Browse the repository at this point in the history
add python3.8 support

Closes: https://bugs.gentoo.org/719474

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Zamarin Arthur <[email protected]>
Closes: gentoo#15529
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
arthurzam authored and juippis committed Apr 29, 2020
1 parent 24712a0 commit e468cb3
Show file tree
Hide file tree
Showing 2 changed files with 83 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/sigil/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST sigil-0.9.16.tar.gz 21241424 BLAKE2B 1e784768cfe98e08ac01f5a9c11ec8254f9a02
DIST sigil-0.9.18.tar.gz 21396185 BLAKE2B a20a1465032371f9d7e567fff03c859adf4bd2264e9d803efeb3bdeb3b097eca826daa36824370848aea50fffb2b2b74b28568f7dca926565dfd0948d7ade030 SHA512 a8f669ffb76554268aae8aa0f85c6861f80def71e429b44b20ac9b231f3f7584839a82e7b6991f57ca1f2d1f023e24d1f37897bd048379e30565e9bdd7ee188a
DIST sigil-1.0.0.tar.gz 21623303 BLAKE2B 5772316d3ffc78387f7fb9db1e88397756bf82c25513246033fe71f288d619844e9316f43b7f08b914e4f59912e42eea061079cd4b468de77087bf7a8ea46be0 SHA512 7fc440131fcdd9af60b10f703dcdaf946ac6c667cabbfc842addd68c6c9af35fc8808630a6cfee6db465e7faeec6a6b4f2c6bbe185426a0f845e47c16b02d7d1
DIST sigil-1.1.0.tar.gz 21370163 BLAKE2B f5e522e6cd6335ef0a897fecdc99f40da5f6be902c02fadc8bf5817bc0e88c4bacab1075995f5da1fd6bbacb8759ab9f20c6810acfeb3736d033241d1ca6f2ed SHA512 855e973b76eee5f06c3efd7f693474c9ea9a30791d0519569696adc4d7737c2ea6036ae932828c7101e78e6903cbdc846a164ba7464ef6c6821b704092cb796e
DIST sigil-1.2.1.tar.gz 21462439 BLAKE2B b615304d80ae1bc8b202398e4e00e25e6f13130ba5f27239d78cb847813fac6d13ddd868ed8daa496b5a5f2f37914603b3014b2c0ecb9f8ae2f0e5f6f2bdf84b SHA512 763648e5c77df9c34568790700f76a1793445f0ba061e2c8c2032c1de72bc5d5c0e0f671d87140df1b4404d571f6c1c73aa99c57208f7383aa2b0d50ed3c15a1
82 changes: 82 additions & 0 deletions app-text/sigil/sigil-1.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="tk"

inherit cmake python-single-r1 xdg-utils

DESCRIPTION="Multi-platform WYSIWYG ebook editor for ePub format"
HOMEPAGE="https://sigil-ebook.com/ https://github.com/Sigil-Ebook/Sigil"
SRC_URI="https://github.com/Sigil-Ebook/Sigil/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+ Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+plugins system-mathjax"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
${PYTHON_DEPS}
app-text/hunspell:=
dev-libs/libpcre:3=[pcre16]
$(python_gen_cond_dep \
'dev-python/css-parser[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]')
>=dev-qt/qtconcurrent-5.12:5
>=dev-qt/qtcore-5.12:5
>=dev-qt/qtgui-5.12:5
>=dev-qt/qtprintsupport-5.12:5
>=dev-qt/qtwebengine-5.12:5[widgets]
>=dev-qt/qtwidgets-5.12:5
sys-libs/zlib[minizip]
plugins? ( $(python_gen_cond_dep \
'dev-python/chardet[${PYTHON_USEDEP}]
dev-python/cssselect[${PYTHON_USEDEP}]
dev-python/cssutils[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/regex[${PYTHON_USEDEP}]') )
system-mathjax? ( dev-libs/mathjax )
"
DEPEND="${RDEPEND}"

BDEPEND="
dev-qt/linguist-tools:5
virtual/pkgconfig
"

S="${WORKDIR}/Sigil-${PV}"

DOCS=( ChangeLog.txt README.md )

src_configure() {
local mycmakeargs=(
-DINSTALL_BUNDLED_DICTS=0
-DUSE_SYSTEM_LIBS=1
-DSYSTEM_LIBS_REQUIRED=1
-DPYTHON_EXECUTABLE="${PYTHON}"
-DPYTHON_LIBRARY="$(python_get_library_path)"
-DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
)
use system-mathjax && mycmakeargs+=( -DMATHJAX_DIR="${EPREFIX}"/usr/share/mathjax )

cmake_src_configure
}

src_install() {
cmake_src_install
python_fix_shebang "${ED}"/usr/share/sigil/
python_optimize "${ED}"/usr/share/sigil/
}

pkg_postinst() {
xdg_desktop_database_update
}

pkg_postrm() {
xdg_desktop_database_update
}

0 comments on commit e468cb3

Please sign in to comment.