Skip to content

Commit

Permalink
games-action/luola: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: Portage-2.3.2, Repoman-2.3.1
  • Loading branch information
austin987 committed Jan 25, 2017
1 parent a27d712 commit e4e4dd8
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 2 deletions.
4 changes: 2 additions & 2 deletions games-action/luola/files/luola-1.3.2-underlink.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/Makefile.am.old 2011-06-17 08:41:40.882481147 +0200
+++ src/Makefile.am 2011-06-17 08:41:58.497602372 +0200
--- a/src/Makefile.am 2011-06-17 08:41:40.882481147 +0200
+++ b/src/Makefile.am 2011-06-17 08:41:58.497602372 +0200
@@ -2,7 +2,7 @@

bin_PROGRAMS = luola
Expand Down
60 changes: 60 additions & 0 deletions games-action/luola/luola-1.3.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils autotools gnome2-utils

DESCRIPTION="A 2D multiplayer arcade game resembling V-Wing"
HOMEPAGE="https://freecode.com/projects/luola"
SRC_URI="mirror://gentoo/${P}.tar.gz
mirror://gentoo/stdlevels-6.0.tar.gz
mirror://gentoo/nostalgia-1.2.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

RDEPEND="media-libs/libsdl[X,sound,joystick,video]
media-libs/sdl-gfx
media-libs/sdl-image[jpeg,png]
media-libs/sdl-mixer
media-libs/sdl-ttf"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}"/${P}-underlink.patch
)

src_prepare() {
default
eautoreconf
}

src_configure() {
econf --enable-sound
}

src_install() {
emake DESTDIR="${D}" install
insinto /usr/share/${PN}/levels
doins "${WORKDIR}"/*.{lev,png}
dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README TODO \
RELEASENOTES.txt ../README.Nostalgia
newdoc ../README README.stdlevels
doicon -s 64 luola.png
make_desktop_entry luola Luola
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit e4e4dd8

Please sign in to comment.