Skip to content

Commit

Permalink
app-metrics/consul_exporter: Prometheus exporter for consul metrics
Browse files Browse the repository at this point in the history
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
william-hubbs authored and williamh committed Apr 15, 2019
1 parent 9377a0a commit e4ec071
Show file tree
Hide file tree
Showing 5 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-metrics/consul_exporter/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST consul_exporter-0.4.0.tar.gz 1107092 BLAKE2B 7f3d6ce797252e5895387d3bbd2a3ad41777bf4d98a4a7a4efc3e8caa0c71fd29be91675ae6fe304016f1cbf87ecf4ee3442b49d3bc08939d471326d4e5d4cd4 SHA512 faac0dfeec5b6fadf73ef68c0d24c059c89891918e498e145a50512b8c961764a02388b2bcce305e12ecf703fa76afdf5634b35aecbee0ac37926d78ce0b1e93
52 changes: 52 additions & 0 deletions app-metrics/consul_exporter/consul_exporter-0.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit user golang-build golang-vcs-snapshot

EGO_PN="github.com/prometheus/consul_exporter"
EGIT_COMMIT="v${PV/_rc/-rc.}"
CONSUL_EXPORTER_COMMIT=75f02d8

DESCRIPTION="Prometheus exporter for consul metrics"
HOMEPAGE="https://github.com/prometheus/consul_exporter"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

DEPEND=">=dev-lang/go-1.11
dev-util/promu"

RESTRICT="strip test"

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
}

src_prepare() {
default
sed -i -e "s/{{.Revision}}/${CONSUL_EXPORTER_COMMIT}/" \
-e "s/{{.Version}}/${PV}/" \
-e "s/-tags netgo/-mod vendor -tags netgo/" \
src/${EGO_PN}/.promu.yml || die "Sed failed"
}

src_compile() {
pushd src/${EGO_PN} || die
GO111MODULE=on GOCACHE="${T}/go-cache" promu build -v || die
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
dobin consul_exporter
dodoc {README,CONTRIBUTING}.md
popd || die
keepdir /var/log/consul_exporter
fowners ${PN}:${PN} /var/log/consul_exporter
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
}
3 changes: 3 additions & 0 deletions app-metrics/consul_exporter/files/consul_exporter.confd
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
# Please set the flags you wish to pass to consul_exporter in
# command_args
# command_args=""
15 changes: 15 additions & 0 deletions app-metrics/consul_exporter/files/consul_exporter.initd
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
#!/sbin/openrc-run
# Copyright 2016-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

description="Consul Exporter for Prometheus"
command="/usr/bin/consul_exporter"
command_background=true
command_user="${RC_SVCNAME}:${RC_SVCNAME}"
error_log=/var/log/consul_exporter/${RC_SVCNAME}.log
output_log=/var/log/consul_exporter/${RC_SVCNAME}.log
pidfile=/var/run/${RC_SVCNAME}.pid

depend() {
after consul net
}
8 changes: 8 additions & 0 deletions app-metrics/consul_exporter/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>William Hubbs</name>
</maintainer>
</pkgmetadata>

0 comments on commit e4ec071

Please sign in to comment.