Skip to content

Commit

Permalink
dev-ros/rospack: add custom patch to return proper package paths with…
Browse files Browse the repository at this point in the history
… our package.xml moved to ros_packages.

Package-Manager: portage-2.3.2
  • Loading branch information
aballier committed Nov 28, 2016
1 parent 8bc7911 commit e504013
Show file tree
Hide file tree
Showing 3 changed files with 21 additions and 1 deletion.
18 changes: 18 additions & 0 deletions dev-ros/rospack/files/gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
Index: rospack-2.3.1/src/rospack.cpp
===================================================================
--- rospack-2.3.1.orig/src/rospack.cpp
+++ rospack-2.3.1/src/rospack.cpp
@@ -191,6 +191,13 @@ class Stackage
break;
}
}
+
+ // On Gentoo we move package.xml to /usr/share/ros_packages/... but need to keep standard stuff in /usr/share, so correct this here.
+ try {
+ fs::path p = fs::canonical("../../" + name_, path_);
+ path_ = p.string();
+ }
+ catch(fs::filesystem_error& e) {};
}

bool isStack() const
Original file line number Diff line number Diff line change
Expand Up @@ -17,6 +17,7 @@ DESCRIPTION="Retrieves information about ROS packages available on the filesyste
LICENSE="BSD"
SLOT="0"
IUSE=""
PATCHES=( "${FILESDIR}/gentoo.patch" )

RDEPEND="dev-libs/boost:=
dev-libs/tinyxml
Expand Down
3 changes: 2 additions & 1 deletion dev-ros/rospack/rospack-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -17,6 +17,7 @@ DESCRIPTION="Retrieves information about ROS packages available on the filesyste
LICENSE="BSD"
SLOT="0"
IUSE=""
PATCHES=( "${FILESDIR}/gentoo.patch" )

RDEPEND="dev-libs/boost:=
dev-libs/tinyxml
Expand Down

0 comments on commit e504013

Please sign in to comment.