Skip to content

Commit

Permalink
gnustep-base/libobjc2: bump to release 2.0 and EAPI 7
Browse files Browse the repository at this point in the history
GNUstep Objective-C Runtime release 2.0. Ebuild now uses EAPI 7.
See also bug #687368.

Bug: https://bugs.gentoo.org/687368
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Ralph Seichter <[email protected]>
Signed-off-by: Bernard Cafarelli <[email protected]>
  • Loading branch information
rseichter authored and voyageur committed Aug 23, 2019
1 parent 74f8c3e commit e5a49a9
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnustep-base/libobjc2/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libobjc2-1.8.1.tar.gz 173635 BLAKE2B 1ed9df6ee934a56dd8565904f9a402f5687bac6f876bcef538fed60c4ebd34af8f35921bdabbdf1ad97fb371e591aea3e47170afaffe65056af07c88e01f0b37 SHA512 518f36e96a82a076fc67fe384226bd97310cd10a53c7b0951db9f3658aa534582b245d5cb97956fe91c38338c3fc8f1e569dd8af36f6d12e32bf1460251d02eb
DIST libobjc2-1.8.tar.gz 173512 BLAKE2B ba494dd2db2bfdcc2cfce906014d75146368f049ebe4ea6b83024705af2b78f916252a084b95be43c245c5fd6574d00db75853d291193ea70cc48a6b5dbeab93 SHA512 1562e42dc43a24c1655d02db7aa101a48a7b026bec23252c8eec3893fbac0d67368685291df0954ee79f07b92ecc13c68ee7c7b0f351428a31e99ed05ed2230d
DIST libobjc2-2.0.tar.gz 191800 BLAKE2B 71f54b1410e20bb638dce4cae8c2cc48ea07acf31a97f1994587a9f6401b725ac393abaef355e9476ef6a0622d80fb6fbe4b3c7f39294e7bedbba17cd4108278 SHA512 2b72506204b8fea6a76688ee96611613c4b7cf98942acc89905c531f4dc997ae0482ff10fa819c2471df6c06d5ebcd251167d8903a4f18d47507cd42baec3748
30 changes: 30 additions & 0 deletions gnustep-base/libobjc2/libobjc2-2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit cmake-utils eutils

DESCRIPTION="GNUstep Objective-C runtime"
HOMEPAGE="http://www.gnustep.org"
SRC_URI="https://github.com/gnustep/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="boehm-gc test"

RDEPEND="boehm-gc? ( dev-libs/boehm-gc )
sys-libs/libcxx"
BDEPEND="${RDEPEND}
sys-devel/clang"

src_configure() {
export CC="clang"
export CXX="clang++"
local mycmakeargs=(
-DGNUSTEP_CONFIG=GNUSTEP_CONFIG-NOTFOUND
-DBOEHM_GC="$(usex boehm-gc)"
-DTESTS="$(usex test)"
)
cmake-utils_src_configure
}

0 comments on commit e5a49a9

Please sign in to comment.