Skip to content

Commit

Permalink
dev-util/pkgconfig: Bump to version 0.29
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.22
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Sep 29, 2015
1 parent 9f89d9b commit e5f5cf6
Show file tree
Hide file tree
Showing 2 changed files with 100 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/pkgconfig/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pkg-config-0.28.tar.gz 1931203 SHA256 6b6eb31c6ec4421174578652c7e141fdaae2dabad1021f420d8713206ac1f845 SHA512 6eafa5ca77c5d44cd15f48457a5e96fcea2555b66d8e35ada5ab59864a0aa03d441e15f54ab9c6343693867b3b490f392c75b7d9312f024c9b7ec6a0194d8320 WHIRLPOOL db4ddb4ce61724e629931c5ffccb4d7a551b4dc0f4efed5a966822307e4b5a786adee5705dd80ec0a9aa32cb1af9ad9615e307360e131fc34688207216161486
DIST pkg-config-0.29.tar.gz 1973875 SHA256 c8507705d2a10c67f385d66ca2aae31e81770cc0734b4191eb8c489e864a006b SHA512 c2857cd67801c0db5d204912453ff6bdc7da3ea61f8b1c6b38983d48dffb958725e7723f909abbc057c7b34a85c27290eec6943808312a75909306076064aa63 WHIRLPOOL 06355dfebc42d3f090ffd02e0e680a0a1d74eb009f4d013f7fe6269d42964c1cdfc2d3ea6e82d3261b818c9b57d30f2c2c82042e97ea0da822875586ba20aa5d
99 changes: 99 additions & 0 deletions dev-util/pkgconfig/pkgconfig-0.29.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

# Do not inherit autotools in non-live ebuild - causes circular dependency, bug #550856
inherit eutils flag-o-matic libtool multilib multilib-minimal

MY_P=pkg-config-${PV}

if [[ ${PV} == *9999* ]]; then
# 1.12 is only needed for tests due to some am__check_pre / LOG_DRIVER
# weirdness with "/bin/bash /bin/sh" in arguments chain with >=1.13
WANT_AUTOMAKE=1.12
EGIT_REPO_URI="git://anongit.freedesktop.org/pkg-config"
EGIT_CHECKOUT_DIR=${WORKDIR}/${MY_P}
inherit autotools git-r3
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
fi

DESCRIPTION="Package config system that manages compile/link flags"
HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"

LICENSE="GPL-2"
SLOT="0"
IUSE="elibc_FreeBSD elibc_glibc hardened internal-glib"

RDEPEND="!internal-glib? ( >=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}] )
!dev-util/pkgconf[pkg-config]
!dev-util/pkg-config-lite
!dev-util/pkgconfig-openbsd[pkg-config]"
DEPEND="${RDEPEND}"

S=${WORKDIR}/${MY_P}

DOCS=( AUTHORS NEWS README )

src_prepare() {
sed -i -e "s|^prefix=/usr\$|prefix=${EPREFIX}/usr|" check/simple.pc || die #434320

epatch_user

if [[ ${PV} == *9999* ]]; then
eautoreconf
else
elibtoolize # Required for FreeMiNT wrt #333429
fi
}

multilib_src_configure() {
local myconf

if use internal-glib; then
myconf+=' --with-internal-glib'
# non-glibc platforms use GNU libiconv, but configure needs to
# know about that not to get confused when it finds something
# outside the prefix too
if use prefix && use !elibc_glibc ; then
myconf+=" --with-libiconv=gnu"
# add the libdir for libtool, otherwise it'll make love with system
# installed libiconv
append-ldflags "-L${EPREFIX}/usr/$(get_libdir)"
fi
else
if ! has_version dev-util/pkgconfig; then
export GLIB_CFLAGS="-I${EPREFIX}/usr/include/glib-2.0 -I${EPREFIX}/usr/$(get_libdir)/glib-2.0/include"
export GLIB_LIBS="-lglib-2.0"
fi
fi

use ppc64 && use hardened && replace-flags -O[2-3] -O1

# Force using all the requirements when linking, so that needed -pthread
# lines are inherited between libraries
use elibc_FreeBSD && myconf+=' --enable-indirect-deps'

[[ ${PV} == *9999* ]] && myconf+=' --enable-maintainer-mode'

ECONF_SOURCE=${S} \
econf \
--docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
--with-system-include-path="${EPREFIX}"/usr/include \
--with-system-library-path="${EPREFIX}"/usr/$(get_libdir) \
${myconf}
}

multilib_src_install() {
emake DESTDIR="${D}" install

if use prefix; then
# Add an explicit reference to $EPREFIX to PKG_CONFIG_PATH to
# simplify cross-prefix builds
echo "PKG_CONFIG_PATH=${EPREFIX}/usr/$(get_libdir)/pkgconfig:${EPREFIX}/usr/share/pkgconfig" >> "${T}"/99${PN}
doenvd "${T}"/99${PN}
fi
}

0 comments on commit e5f5cf6

Please sign in to comment.