Skip to content

Commit

Permalink
media-gfx/graphite2: Switch to cmake.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jan 3, 2020
1 parent a8f78da commit e630067
Showing 1 changed file with 6 additions and 5 deletions.
11 changes: 6 additions & 5 deletions media-gfx/graphite2/graphite2-1.3.13.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,11 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7} )

CMAKE_ECLASS=cmake
GENTOO_DEPEND_ON_PERL="no"
inherit perl-module python-any-r1 cmake-multilib

Expand Down Expand Up @@ -47,7 +48,7 @@ python_check_deps() {
}

src_prepare() {
cmake-utils_src_prepare
cmake_src_prepare

# make tests optional
if ! use test; then
Expand All @@ -65,11 +66,11 @@ multilib_src_configure() {
-DGRAPHITE2_NSEGCACHE:BOOL=ON
)

cmake-utils_src_configure
cmake_src_configure

# fix perl linking
if multilib_is_native_abi && use perl; then
# we rely on the fact that cmake-utils_src_configure sets BUILD_DIR
# we rely on the fact that cmake_src_configure sets BUILD_DIR
sed -e "s:@BUILD_DIR@:\"${BUILD_DIR}/src\":" \
-i "${S}"/contrib/perl/Build.PL || die
fi
Expand All @@ -86,7 +87,7 @@ src_compile() {

multilib_src_test() {
if multilib_is_native_abi; then
cmake-utils_src_test
cmake_src_test
else
einfo "Cannot test since python is not multilib."
fi
Expand Down

0 comments on commit e630067

Please sign in to comment.