Skip to content

Commit

Permalink
games-engines/scummvm-tools: Bump to version 2.0.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Dec 18, 2017
1 parent 679b6a0 commit e86e1c1
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-engines/scummvm-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST scummvm-tools-1.8.0.tar.xz 864048 BLAKE2B 7e3184bda33c582708be204493cd99504ef7286305ba01d052a95bf317c56630109e963ecd8d26d4f8868bb75e5b0cb22154fe4cb794a01dabe25b11568babbb SHA512 eed0aa0cceef59c42aabe94fe382a4494085c479d310cb624131746a1cbacc37d4a43603a5321167eb5fd4d9d8235fc794bdca5a3417fc4d224213e5409347ed
DIST scummvm-tools-2.0.0.tar.xz 866668 BLAKE2B 51e6a771f0b1902f9cadc1e84da4b97aa42bc810c781ba238b3dad9ce242792d0de805e6d129607bace36b7a3cb8dc7a7a1a6fd13211320afe6546569b49f0ff SHA512 a4c645f2a05b5f208658bad1a3122115a3077809141f5d4b281414ca32854d14987a8b6d4579f3bdd9d3eeeab880d98e3b540c3f69155197f20a2094a7812c60
58 changes: 58 additions & 0 deletions games-engines/scummvm-tools/scummvm-tools-2.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
WX_GTK_VER=3.0
inherit wxwidgets eutils flag-o-matic

DESCRIPTION="utilities for the SCUMM game engine"
HOMEPAGE="http://scummvm.sourceforge.net/"
SRC_URI="http://scummvm.org/frs/scummvm-tools/${PV}/${P}.tar.xz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
IUSE="flac iconv mad png vorbis"
RESTRICT="test" # some tests require external files

RDEPEND=">=dev-libs/boost-1.32
sys-libs/zlib
x11-libs/wxGTK:${WX_GTK_VER}
flac? ( media-libs/flac )
iconv? ( virtual/libiconv media-libs/freetype:2 )
mad? ( media-libs/libmad )
png? ( media-libs/libpng:0 )
vorbis? ( media-libs/libvorbis )"
DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/pkgconfig"

PATCHES=(
"${FILESDIR}/${PN}-1.8.0-binprefix.patch"
)

src_prepare() {
default

need-wxwidgets unicode
rm -rf *.bat dists/win32 || die
sed -ri -e '/^(CC|CXX)\b/d' Makefile || die
}

src_configure() {
# Not an autoconf script
./configure \
--disable-tremor \
--enable-verbose-build \
--mandir=/usr/share/man \
$(use_enable flac) \
$(use_enable iconv) \
$(use_enable iconv freetype) \
$(use_enable mad) \
$(use_enable png) \
$(use_enable vorbis) || die
}

src_install() {
EXEPREFIX="${PN}-" default
}

0 comments on commit e86e1c1

Please sign in to comment.