Skip to content

Commit

Permalink
app-misc/cdspeed: EAPI7, improve ebuild
Browse files Browse the repository at this point in the history
Closes: gentoo#9411
  • Loading branch information
mm1ke authored and a17r committed Aug 15, 2018
1 parent e6f3e4a commit e955172
Showing 1 changed file with 30 additions and 0 deletions.
30 changes: 30 additions & 0 deletions app-misc/cdspeed/cdspeed-0.4-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="Change the speed of your CD drive"
HOMEPAGE="http://linuxfocus.org/~guido/"
SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~x86"

src_prepare() {
default
sed -i Makefile \
-e 's| -o | $(LDFLAGS)&|g' \
|| die "sed Makefile failed"
}

src_compile() {
emake CFLAGS="${CFLAGS} -Wall -Wno-unused" CC=$(tc-getCC)
}

src_install() {
emake PREFIX="${D}/usr" install
dodoc README
}

0 comments on commit e955172

Please sign in to comment.