Skip to content

Commit

Permalink
games-fps/darkplaces: fix pre-stripped files, respecting CC
Browse files Browse the repository at this point in the history
Can't reproduce CFLAGS issue right now.

Closes: https://bugs.gentoo.org/739194
Closes: https://bugs.gentoo.org/739200
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 25, 2021
1 parent 6b44b84 commit e97bb8a
Showing 1 changed file with 18 additions and 5 deletions.
23 changes: 18 additions & 5 deletions games-fps/darkplaces/darkplaces-20140513-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils flag-o-matic unpacker
EAPI=7

inherit desktop flag-o-matic wrapper unpacker

# Latest versions are in http://icculus.org/twilight/darkplaces/files/
MY_PV="${PV/_beta/beta}"
Expand All @@ -18,6 +19,7 @@ SRC_URI="http://icculus.org/twilight/${PN}/files/${MY_ENGINE}
lights? (
http://www.fuhquake.net/files/extras/${MY_LIGHTS}
http://www.kgbsyndicate.com/romi/id1.pk3 )"
S="${WORKDIR}/${PN}"

LICENSE="GPL-2"
SLOT="0"
Expand Down Expand Up @@ -60,14 +62,17 @@ DEPEND="lights? ( || (
!opengl? ( !sdl? ( !dedicated? (
${UIRDEPEND}
${UIDEPEND} ) ) )
virtual/pkgconfig
"
BDEPEND="
app-arch/unzip
virtual/pkgconfig
"

S="${WORKDIR}/${PN}"
dir="/usr/share/quake1"

opengl_client() { use opengl || ( ! use dedicated && ! use sdl ) }
opengl_client() {
use opengl || ( ! use dedicated && ! use sdl )
}

src_unpack() {
if use lights ; then
Expand All @@ -76,6 +81,7 @@ src_unpack() {
mv *.lit maps/ || die
mv ReadMe.txt rtlights.txt
fi

unpack "${MY_ENGINE}"
unpack ./${PN}*.zip
}
Expand Down Expand Up @@ -115,6 +121,12 @@ src_prepare() {
src_compile() {
local opts="DP_FS_BASEDIR=\"${dir}\" DP_LINK_TO_LIBJPEG=1"

# Protect against people choosing a strip implementation
# bug #739194
opts+="STRIP=true"

tc-export CC

# Preferred sound is alsa
local sound_api="NULL"
use oss && sound_api="OSS"
Expand Down Expand Up @@ -168,6 +180,7 @@ src_install() {
if use lights ; then
insinto "${dir}"/id1
doins -r "${WORKDIR}"/{cubemaps,maps}

if use demo ; then
# Set up symlinks, for the demo levels to include the lights
local d
Expand Down

0 comments on commit e97bb8a

Please sign in to comment.