Skip to content

Commit

Permalink
media-libs/virglrenderer: version bump to 0.9.1
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/796353
Closes: https://bugs.gentoo.org/743106
Closes: https://bugs.gentoo.org/797292
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Matthias Maier <[email protected]>
  • Loading branch information
tamiko committed Jun 27, 2021
1 parent 6a3c5bf commit e9a931b
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/virglrenderer/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST virglrenderer-0.8.2.tar.gz 2697672 BLAKE2B 2c5b14fcca8ed778a674c35f3a88213d017f0cb30afcd5c28a13f8ea8d9d2fcb052150451cf0c9e7b48f0619fa93c9cc9036b59677fdae09ec97517984af43c1 SHA512 a64069bf6a28e5b77da53b5226a447decc3fe07a5c28bc49c2c15413b7651605170c5644a24f6a0ce9216a0f55afcee0246c3e4d9bc8f32dad771be3115e0f2a
DIST virglrenderer-0.9.1.tar.gz 2945799 BLAKE2B 86740155a824263b8ecb3a917db59996650e90a095e64be3cb6119eb2b6c5a64b6b3f5d40354fdf9d5bb4dae7d247749a8ddcfb33031aa2607057d18cedc319c SHA512 4edba82c83a6183871f74f365d55af88935edf9abad97c1617c569f21a16b008481364f50491dfbc7ed89832a6b618fce98d182f84cc1cbab9d2c7443a2ae936
46 changes: 46 additions & 0 deletions media-libs/virglrenderer/virglrenderer-0.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit eutils meson

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/virglrenderer.git"
inherit git-r3
else
SRC_URI="https://gitlab.freedesktop.org/virgl/${PN}/-/archive/${P}/${PN}-${P}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

DESCRIPTION="library used implement a virtual 3D GPU used by qemu"
HOMEPAGE="https://virgil3d.github.io/"

LICENSE="MIT"
SLOT="0"
IUSE="static-libs"

RDEPEND="
>=x11-libs/libdrm-2.4.50
media-libs/libepoxy"

DEPEND="${RDEPEND}"

# Most of the testuiste cannot run in our sandboxed environment, just don't
# deal with it for now.
RESTRICT="test"

S=${WORKDIR}/${PN}-${P}

src_configure() {
local emesonargs=(
-Ddefault_library=$(usex static-libs both shared)
)

meson_src_configure
}

src_install() {
meson_src_install
find "${ED}"/usr -name 'lib*.la' -delete
}

0 comments on commit e9a931b

Please sign in to comment.