Skip to content

Commit

Permalink
dev-cpp/glibmm: bump to 2.56.1
Browse files Browse the repository at this point in the history
Signed-off-by: Mart Raudsepp <[email protected]>
Package-Manager: Portage-2.3.52, Repoman-2.3.11
  • Loading branch information
leio committed Dec 6, 2018
1 parent a192dc9 commit ea350fc
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/glibmm/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST glibmm-2.50.1.tar.xz 6444576 BLAKE2B dbbdb79d8de9510f9bec770523ca7f4c93d287
DIST glibmm-2.52.1.tar.xz 6451164 BLAKE2B 740178b51a2263ecc4778833fa6f2fd3913cdfc4e93b1a732a1b0ec9d43eb4ed60ab6bea48e02081d75a3ec1f98a149ebff47ced54dcce07e7ae011b2d20452d SHA512 702158762cb28972b315ab98dc00a62e532bda08b6e76dc2a2556e8cb381c2021290891887a4af2fbff5a62bab4d50581be73037dc8e0dc47d5febd6cbeb7bda
DIST glibmm-2.54.1.tar.xz 6837384 BLAKE2B 98e4acb5b80786a27195bea43cc425a45219078ef839e97c60c9e3f52b3a0b3c928e19469d679529b5091d8ac1953d4f315ea75618c3fcc8f33d15f6565b5783 SHA512 94f2a4d6972684e25e38ff2e6bcfc1e9c5e4d096856d3419320c14166e27e26b1ad69be434337e9b70c23842989988113521aae7a800ef2f29e81f1ae6c25a13
DIST glibmm-2.56.0.tar.xz 6859520 BLAKE2B 8d7f0120de211002d587e6ec0d3750dcdce60abae6506395b318be876d5ed680b1451920063f06d6d9655137d50482a9ba936caa0f6da127bb3855e43b4d877f SHA512 65e577009019e30e340ae5fe6e4c854e5a75551b2eb83ad85403d73eb4e77879783162d4c3c354bc37be0be842f0ddffc1977021a5e0c32985fb596d86929c08
DIST glibmm-2.56.1.tar.xz 6841240 BLAKE2B db0e1402f322fd31138cf4db2fc2fabb6fb9896f226f98bd524fe005f0e3412f6973774571b7ec79a9e3c79f6622b0969a55dc91631cc996906dd1e558ad4fe8 SHA512 fd5ad19c5dcba484573520e1d00b5bbb600ee805ab8cd9c0d985880cc1bcbe67ad31fa9f2b5789b5892eddd6be345e3f308593e5ef021e1cfda132e4235fb735
65 changes: 65 additions & 0 deletions dev-cpp/glibmm/glibmm-2.56.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit gnome2 multilib-minimal

DESCRIPTION="C++ interface for glib2"
HOMEPAGE="https://www.gtkmm.org"

LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="doc debug test"

RDEPEND="
>=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
>=dev-libs/glib-2.55.1:2[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )
"
# dev-cpp/mm-common needed for eautoreconf

src_prepare() {
if ! use test; then
# don't waste time building tests
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
-i Makefile.am Makefile.in || die "sed 1 failed"
fi

# don't build examples - we want to install example sources, not binaries
sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
-i Makefile.am Makefile.in || die "sed 2 failed"

gnome2_src_prepare
}

multilib_src_configure() {
ECONF_SOURCE="${S}" gnome2_src_configure \
$(use_enable debug debug-refcounting) \
$(multilib_native_use_enable doc documentation) \
--enable-deprecated-api
}

multilib_src_test() {
cd tests
default

for i in */test; do
${i} || die "Running tests failed at ${i}"
done
}

multilib_src_install() {
gnome2_src_install
}

multilib_src_install_all() {
einstalldocs

find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
dodoc -r examples
}

0 comments on commit ea350fc

Please sign in to comment.