Skip to content

Commit

Permalink
net-dns/knot: bump to 3.0.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Signed-off-by: Pierre-Olivier Mercier <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
nemunaire authored and thesamesam committed Feb 5, 2021
1 parent 9bc56fe commit ea7f5be
Show file tree
Hide file tree
Showing 2 changed files with 103 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-dns/knot/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST knot-2.9.7.tar.xz 1188904 BLAKE2B f20355f211db316a1e39321a1200130e2af4e895e
DIST knot-2.9.8.tar.xz 1194284 BLAKE2B c4329e5b2fc499851112d008af10c1a73bbe50cd07a4b5af984e99f389606b6f11c0b321dc26c14f872eb7cc70a99290a033f9aa9ff23a2b3694427605ffc704 SHA512 8104c3bdef2db4a79d6cd0fa4a30be1aa6edfa01363b97738d873445198cd031b4f5ab581d1a5277de49a8a042bb5340334be0579ceefa4b614e34c2cd454904
DIST knot-3.0.2.tar.xz 1313864 BLAKE2B f2ff8c75a9b239b924af2eecc5e5afed27030fc9be6e112a4f61479f40247396c1d2905f58329fa84907c6ce796bc9a56d6f8e1cc83b737e15713844e0add32f SHA512 677de7a80688d4820d56c020af1bb1da97546f44a616e2d72d7e0301fca4a7ab682994cf66e8c37403e65ddb45ea3e0eb37b3304739c1239364115588c589699
DIST knot-3.0.3.tar.xz 1322748 BLAKE2B a0b9a99b66d1f02d0e631226c328376d2ca780b19522040525a7a4e9ec24bd22e0f0094ee98a01a75695727619b60b28d72484b3da4f5c92b63c368665aa637a SHA512 4a4de22f8324d8459a7012faa49fb1503ad3b2f23af434a82381a73bf3f43a66f096bba7b0dfc8a61f416d9e02ce97c449ed1590a8a899279ac793798423c339
DIST knot-3.0.4.tar.xz 1347928 BLAKE2B c97df0c04dbd6b96d2f2805a2bbb07bc3fd0ac64160619a55fdf93ac02e6d3f797dfae43ac8bc79450c59c88e0a521911517577ea19d67bb41186cfcd07dd743 SHA512 d674faaafcbe882539d28e53f1cd6cdda61ca8065f66dc0b9127f249f34b59a9d3d1ac206799c2974a2d38264842a2387db35f814bd05f3eaeac0b35b90b21ac
102 changes: 102 additions & 0 deletions net-dns/knot/knot-3.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd

DESCRIPTION="High-performance authoritative-only DNS server"
HOMEPAGE="https://www.knot-dns.cz/"
SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

KNOT_MODULES=(
"+cookies"
"+dnsproxy"
"dnstap"
"geoip"
"+noudp"
"+onlinesign"
"+queryacl"
"+rrl"
"+stats"
"+synthrecord"
"+whoami"
)
IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"

RDEPEND="
acct-group/knot
acct-user/knot
dev-db/lmdb
dev-libs/libedit
dev-libs/userspace-rcu:=
dev-python/lmdb
net-libs/gnutls:=
caps? ( sys-libs/libcap-ng )
dnstap? (
dev-libs/fstrm
dev-libs/protobuf-c:=
)
geoip? ( dev-libs/libmaxminddb:= )
idn? (
!libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
libidn2? ( net-dns/libidn2:= )
)
systemd? ( sys-apps/systemd:= )
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
doc? ( dev-python/sphinx )
"

S="${WORKDIR}/${P/_/-}"

src_configure() {
local u
local my_conf=(
--with-storage="${EPREFIX}/var/lib/${PN}"
--with-rundir="${EPREFIX}/var/run/${PN}"
$(use_enable fastparser)
$(use_enable dnstap)
$(use_enable doc documentation)
$(use_enable utils utilities)
--enable-systemd=$(usex systemd)
$(use_with idn libidn)
)

for u in "${KNOT_MODULES[@]#+}"; do
my_conf+=("$(use_with ${u} module-${u})")
done

econf "${my_conf[@]}"
}

src_compile() {
default

use doc && emake -C doc html
}

src_test() {
emake check
}

src_install() {
use doc && local HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )

default

rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die

newinitd "${FILESDIR}/knot.init" knot
if use systemd; then
systemd_newunit "${FILESDIR}/knot-1.service" knot.service
fi

find "${D}" -name '*.la' -delete || die
}

0 comments on commit ea7f5be

Please sign in to comment.