Skip to content

Commit

Permalink
dev-libs/leatherman: 1.9.0 stable amd64/x86 and 1.9.1 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Nov 30, 2019
1 parent 817016b commit ea8d868
Show file tree
Hide file tree
Showing 3 changed files with 60 additions and 1 deletion.
1 change: 1 addition & 0 deletions dev-libs/leatherman/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST leatherman-1.3.0.tar.gz 434229 BLAKE2B e0c19bca2378afc4928554ac0862543504ba725aadc6cffd78220f7f7f1b725cad960fc6d9fdd2d54a43c233b35959ebcb9c71d1191a5535703599fa32e3301e SHA512 5e06be7add652f69b0d4a8d778e33dfb68183c4d598217cc6542d2431f7984f0af989c27bd69e89b77ab03d6dd2adab9d70f68cd87dae20d8e24ae05923fbe9b
DIST leatherman-1.8.0.tar.gz 815287 BLAKE2B a8377cedac49e0845e689e4e8ff58fb59e6e59c77e8cd363774d22650b4b286d85e0b5e52b926c3e4169ba2eadf9fc50f16f5161001a16f63c49f3ca66c996cc SHA512 fb308025f0807b12527fe6fc287fee861eb27b6987df38c03e1da73c477aec5a2a6c92860c983c4cc10282388ee34f2cf657a38831db007519c471f815f492f6
DIST leatherman-1.9.0.tar.gz 815504 BLAKE2B 62b4b9aeca3279b7f89fba1c3a7655e59c5d490cb44ba92e4c2dfe5ffa78eeb02a448bd6c6e6b08c324531b799ab5d1800a3b57c4e490794f76bf9737db16963 SHA512 d8e0fe7f165845056a0308241ef0e656077269cd6cbc656b1a72295ff475e813d3f523c8d45b14d7e10a8deebe786ac7fc836c46d4230142812a9c0362cd8967
DIST leatherman-1.9.1.tar.gz 815756 BLAKE2B a0c8777531b066e247d8abfefc1b22fec825f7db22ef67cad6a703a7cd168f19349b13b923841e8064eec1e7bc7b755181b58370c7501b37710ac376687c5b43 SHA512 51dc356ec7196c7538fac154a094d3693de5ef89d50a07651753c400daff3ecdfbfe46516ffecfa592484aa1ec8afb891f2f2b6be62c94a8f0ab08a3bba65786
2 changes: 1 addition & 1 deletion dev-libs/leatherman/leatherman-1.9.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz

LICENSE="Apache-2.0"
IUSE="debug static-libs test"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
SLOT="0/${PV}"

RDEPEND="net-misc/curl"
Expand Down
58 changes: 58 additions & 0 deletions dev-libs/leatherman/leatherman-1.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils multilib

DESCRIPTION="A C++ toolkit"
HOMEPAGE="https://github.com/puppetlabs/leatherman"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
IUSE="debug static-libs test"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
SLOT="0/${PV}"

RDEPEND="net-misc/curl"
DEPEND=">=dev-libs/boost-1.54:=[nls]
net-misc/curl
>=sys-devel/gcc-4.8:*"

PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )

src_prepare() {
sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DCMAKE_VERBOSE_MAKEFILE=ON
-DCMAKE_BUILD_TYPE=None
-DCMAKE_INSTALL_PREFIX=/usr
)
if ! use static-libs; then
mycmakeargs+=(
-DLEATHERMAN_SHARED=ON
)
else
mycmakeargs+=(
-DLEATHERMAN_SHARED=OFF
)
fi
if use debug; then
mycmakeargs+=(
-DCMAKE_BUILD_TYPE=Debug
)
fi
cmake-utils_src_configure
}

src_test() {
"${WORKDIR}/${P}"_build/bin/leatherman_test
}

src_install() {
cmake-utils_src_install
}

0 comments on commit ea8d868

Please sign in to comment.