Skip to content

Commit

Permalink
dev-ros/image_rotate: Backport upstream patch to build with gcc6.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
aballier committed Jan 23, 2017
1 parent a393100 commit eaf433a
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 1 deletion.
34 changes: 34 additions & 0 deletions dev-ros/image_rotate/files/gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
commit 6c2d65452bd5fe62723988a1a570789921900d59
Author: Lukas Bulwahn <[email protected]>
Date: Fri Sep 30 15:39:47 2016 +0200

address gcc6 build error

With gcc6, compiling fails with `stdlib.h: No such file or directory`,
as including '-isystem /usr/include' breaks with gcc6, cf.,
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.

This commit addresses this issue for this package in the same way
it was addressed in various other ROS packages. A list of related
commits and pull requests is at:

https://github.com/ros/rosdistro/issues/12783

Signed-off-by: Lukas Bulwahn <[email protected]>

diff --git a/image_rotate/CMakeLists.txt b/image_rotate/CMakeLists.txt
index 04ba03b..75d8e77 100644
--- a/image_rotate/CMakeLists.txt
+++ b/image_rotate/CMakeLists.txt
@@ -12,10 +12,7 @@ find_package(OpenCV REQUIRED core imgproc)
find_package(Eigen REQUIRED)

# add the executable
-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
- ${EIGEN_INCLUDE_DIRS}
- ${OpenCV_INCLUDE_DIRS}
-)
+include_directories(${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})

add_library(${PROJECT_NAME} SHARED src/nodelet/image_rotate_nodelet.cpp)
target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES} ${OpenCV_LIBRARIES})
3 changes: 2 additions & 1 deletion dev-ros/image_rotate/image_rotate-1.12.19.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -26,3 +26,4 @@ RDEPEND="
dev-ros/tf2_geometry_msgs
"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/gcc6.patch" )

0 comments on commit eaf433a

Please sign in to comment.