forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/cinnamon-desktop: New upstream version 3.8.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
- Loading branch information
Showing
2 changed files
with
62 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST cinnamon-desktop-3.6.2.tar.gz 571728 BLAKE2B 17a3297b75a1ba9e34ff5ef8b7252748b4300fe40381b8d5942fcf5baaf7532a560cdbd918d2dc7ed34921e357c61f74d947a5e2174cd7b0310f91015a4bc4f4 SHA512 75af7ec916d43d02eebe9a83214cdb538067f6b674ca76e109f3bed909e61df11ec83350e97505ddaaed24f097e7b20512822e30b52d14a39d6a0e3d582d05fb | ||
DIST cinnamon-desktop-3.8.1.tar.gz 489295 BLAKE2B cc2216040387ff573d4cfc740e7e400862c8fc1361f38b2771ac94c490a8710e487ae1d33ab1a7ed98423c94e77bba32db6cbc563e9152c67b011459f91ad123 SHA512 d4b5e6d848a4cb01e811410da8b07d2a400f6632abba9cc0ed74e5321ba3fafd1ec9ac90307eb56ba7047dbfabbad9526e1348533c6207c9a7756c24751da933 |
61 changes: 61 additions & 0 deletions
61
gnome-extra/cinnamon-desktop/cinnamon-desktop-3.8.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python3_{4,5,6} ) | ||
|
||
inherit meson eutils gnome2 python-single-r1 | ||
|
||
DESCRIPTION="A collection of libraries and utilites used by Cinnamon" | ||
HOMEPAGE="http://cinnamon.linuxmint.com/" | ||
SRC_URI="https://github.com/linuxmint/cinnamon-desktop/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+ FDL-1.1+ LGPL-2+" | ||
SLOT="0/4" # subslot = libcinnamon-desktop soname version | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+introspection systemd" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
COMMON_DEPEND="${PYTHON_DEPS} | ||
>=dev-libs/glib-2.37.3:2[dbus] | ||
media-sound/pulseaudio[glib] | ||
>=x11-libs/gdk-pixbuf-2.22:2[introspection?] | ||
>=x11-libs/gtk+-3.3.16:3[introspection?] | ||
>=x11-libs/libXext-1.1 | ||
>=x11-libs/libXrandr-1.3 | ||
x11-libs/cairo:=[X] | ||
x11-libs/libX11 | ||
x11-libs/libxkbfile | ||
x11-misc/xkeyboard-config | ||
>=gnome-base/gsettings-desktop-schemas-3.5.91 | ||
introspection? ( >=dev-libs/gobject-introspection-0.9.7:= ) | ||
sys-apps/accountsservice | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
dev-python/pygobject:3[${PYTHON_USEDEP}] | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-util/gtk-doc-am-1.4 | ||
>=dev-util/intltool-0.40.6 | ||
gnome-base/gnome-common | ||
x11-base/xorg-proto | ||
virtual/pkgconfig | ||
" | ||
|
||
pkg_setup() { | ||
python_setup | ||
} | ||
|
||
src_configure() { | ||
meson_src_configure | ||
} | ||
|
||
src_install() { | ||
meson_src_install | ||
|
||
# set sane default gschema values for systemd users | ||
if use systemd; then | ||
insinto /usr/share/glib-2.0/schemas/ | ||
newins "${FILESDIR}"/${PN}-2.6.4.systemd.gschema.override ${PN}.systemd.gschema.override | ||
fi | ||
} |