Skip to content

Commit

Permalink
games-board/gnubg: enable py3.10
Browse files Browse the repository at this point in the history
Technically eautoreconf could be behind `use python` (and
autoconf-archive is guaranteed if python is installed), but
do not want to introduce use-conditional autoconf variance
(eautoreconf may also be useful for other reasons in the future).

Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Nov 17, 2021
1 parent 1dfd4cf commit ec9ea95
Showing 1 changed file with 11 additions and 5 deletions.
16 changes: 11 additions & 5 deletions games-board/gnubg/gnubg-1.06.002-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7,8,9} )
inherit desktop python-single-r1 xdg
PYTHON_COMPAT=( python3_{8..10} )
inherit autotools desktop python-single-r1 xdg

DESCRIPTION="GNU BackGammon"
HOMEPAGE="https://www.gnu.org/software/gnubg/"
Expand Down Expand Up @@ -33,6 +33,7 @@ RDEPEND="
virtual/libintl"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/autoconf-archive
sys-devel/gettext
virtual/pkgconfig"

Expand All @@ -45,18 +46,23 @@ src_prepare() {

# use ${T} instead of /tmp for constructing credits (bug #298275)
sed -i -e 's:/tmp:${T}:' credits.sh || die
sed -i -e 's/fonts //' Makefile.in || die # handle font install ourself to fix bug #335774
sed -i -e 's/fonts //' Makefile.am || die # handle font install ourself to fix bug #335774
sed -i \
-e '/^localedir / s#=.*$#= @localedir@#' \
-e '/^gnulocaledir / s#=.*$#= @localedir@#' \
po/Makefile.in.in || die
sed -i \
-e '/^gnubgiconsdir / s#=.*#= /usr/share#' \
-e '/^gnubgpixmapsdir / s#=.*#= /usr/share/pixmaps#' \
pixmaps/Makefile.in || die
pixmaps/Makefile.am || die
sed -i \
-e '1i#include <config.h>' \
copying.c || die #551896

# use system's copy so py3.10 distutils warning doesn't trigger a fatal error
rm m4/ax_python_devel.m4 || die

eautoreconf
}

src_configure() {
Expand Down

0 comments on commit ec9ea95

Please sign in to comment.