Skip to content

Commit

Permalink
dev-python/hcloud-python: Version bump to 1.4.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Agostino Sarubbo <[email protected]>
  • Loading branch information
asarubbo committed Sep 2, 2019
1 parent 26575d9 commit eccbc99
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/hcloud-python/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST hcloud-python-1.2.1.tar.gz 63592 BLAKE2B 9a6d2dae97ff405ebd9b92bc833c9d953c13840e68be4eb43fed375a60e55cf4bf9b4b742b26fb03401f631b7f7127815961861cb673adf4839c829141c8ed00 SHA512 cb70d190350457fc3c6e474bc6c943070102762595dac2f386041956f64255f390a928a2f2411be861645cd65b015ab9e0c931b36aeed0076b06d9f67ac72d1c
DIST hcloud-python-1.3.0.tar.gz 71208 BLAKE2B 1a074f64aaff87991ef5c565bb8976184a1f5ca54c0d2fe19ac3dc4f8425d3a2d92ef13cbcec7ecbfb8958572ab5561953098cf0ed9f141ba43c3eb0a90ffc10 SHA512 6dfff2301ad91db3c79fc8f68a05b5a886f86824a34f044d14a6a35771d23fdba9764055c797d11f404cccf3ae6338af940e4814113859d7809733629d7c2659
DIST hcloud-python-1.4.1.tar.gz 71379 BLAKE2B 8f6f0a4e23dd3b99bd4375644ebdd161fb0c305773ccf10992fdcc05cefa37ad58e33eb0516eccd377ebb642749f5014ed5baad4d37f3eea91cece7eeaac0c56 SHA512 3eff15d6b46caa2b46f398f26efc1f986af0818253888ee42c97652f5d0369738558eea57e6ca934c4f7e88fea379f5a0e9e671908717f07cf32ec74d8415d42
38 changes: 38 additions & 0 deletions dev-python/hcloud-python/hcloud-python-1.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )

inherit distutils-r1

DESCRIPTION="Official Hetzner Cloud python library"
HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc examples"

COMMON_DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/requests-2.20[${PYTHON_USEDEP}]
<dev-python/requests-2.23[${PYTHON_USEDEP}]"

DEPEND="${COMMON_DEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"

RDEPEND="${COMMON_DEPEND}
dev-python/future[${PYTHON_USEDEP}]"

python_compile_all() {
use doc && emake -C docs html
}

python_install_all() {
use examples && dodoc -r examples
use doc && local HTML_DOCS=( docs/_build/html/. )

distutils-r1_python_install_all
}

0 comments on commit eccbc99

Please sign in to comment.