Skip to content

Commit

Permalink
app-doc/zeal: Fix build w/ Qt 5.15, use cmake.eclass, fix src_prepare
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/728462
Package-Manager: Portage-2.3.101, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jun 16, 2020
1 parent f8ea6c9 commit ecd03b6
Show file tree
Hide file tree
Showing 2 changed files with 30 additions and 7 deletions.
21 changes: 21 additions & 0 deletions app-doc/zeal/files/zeal-0.6.1-qt-5.15.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
From 064aaa05d6a3ba4ba3cf648199a3109aba2f41fe Mon Sep 17 00:00:00 2001
From: Dmitry Atamanov <[email protected]>
Date: Sun, 26 Apr 2020 02:26:53 +0500
Subject: [PATCH] fix(ui): fix compilation error with Qt 5.15 (#1218)

---
src/libs/ui/searchitemdelegate.cpp | 1 +
1 file changed, 1 insertion(+)

diff --git a/src/libs/ui/searchitemdelegate.cpp b/src/libs/ui/searchitemdelegate.cpp
index 464e4859..4a9c473b 100644
--- a/src/libs/ui/searchitemdelegate.cpp
+++ b/src/libs/ui/searchitemdelegate.cpp
@@ -27,6 +27,7 @@
#include <QFontMetrics>
#include <QHelpEvent>
#include <QPainter>
+#include <QPainterPath>
#include <QToolTip>

using namespace Zeal::WidgetUi;
16 changes: 9 additions & 7 deletions app-doc/zeal/zeal-0.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils xdg-utils
inherit cmake xdg-utils

DESCRIPTION="Offline documentation browser inspired by Dash"
HOMEPAGE="https://zealdocs.org/"
Expand All @@ -12,7 +12,6 @@ SRC_URI="https://github.com/zealdocs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="vanilla"

DEPEND="
Expand All @@ -33,13 +32,16 @@ RDEPEND="
x11-themes/hicolor-icon-theme
"

PATCHES=(
"${FILESDIR}/0001-libs-enforce-static-linking-of-internal-libs.patch"
"${FILESDIR}/${P}-qt-5.15.patch"
)

src_prepare() {
default
eapply "${FILESDIR}/0001-libs-enforce-static-linking-of-internal-libs.patch"
if ! use vanilla; then
eapply "${FILESDIR}/0002-settings-disable-checking-for-updates-by-default.patch"
PATCHES+=( "${FILESDIR}/0002-settings-disable-checking-for-updates-by-default.patch" )
fi
cmake-utils_src_prepare
cmake_src_prepare
}

pkg_postinst() {
Expand Down

0 comments on commit ecd03b6

Please sign in to comment.