Skip to content

Commit

Permalink
dev-python/lesscpy: Add 0.14.0 with python3_{7,8}
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: John Helmert III <[email protected]>
Bug: https://bugs.gentoo.org/719042
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
ajakk authored and prometheanfire committed May 5, 2020
1 parent c429970 commit ed01f30
Show file tree
Hide file tree
Showing 2 changed files with 29 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/lesscpy/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lesscpy-0.13.0.tar.gz 157854 BLAKE2B 2a06827233e5142249298c75d323ffaed2cf497f5ddf86023e65235417f3fb970e66a6b112e9eeb38f24868ab98a6d4b9bcb0cf8a53a2121fff44098fdde459a SHA512 227db8212a386b06f288140d09b7505ae43bc6221396fa2d154a6d7f0831cf1ff005d9818fd85fb3804103b725b60827cf56a29930c2de928546ab0dcf3d5877
DIST lesscpy-0.14.0.tar.gz 186505 BLAKE2B 6c7f4691c352573d081436d5f31ddacbd6b054810f07feafaf654a5c401d98c3274f86f03f68534f661b79bff3d708eb09bfdc0e3b9e800b7e2091060e64c370 SHA512 333015e3d4169fafedf0c295d12d5f0eadb8bea2576d147f1461e5854638b0501ea3038a945924efd81629b66dcc7ffcd3fabd12933529cb5fd4b962e87fe2c3
28 changes: 28 additions & 0 deletions dev-python/lesscpy/lesscpy-0.14.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8} )
DISTUTILS_USE_SETUPTOOLS=rdepend

inherit distutils-r1

RESTRICT="!test? ( test )"

DESCRIPTION="A compiler written in Python for the LESS language"
HOMEPAGE="https://pypi.org/project/lesscpy/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

BDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND="dev-python/ply[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"

python_test() {
nosetests -v || die "tests failed under ${EPYTHON}"
}

0 comments on commit ed01f30

Please sign in to comment.