Skip to content

Commit

Permalink
dev-ruby/autoprefixer-rails: add 9.8.6.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Sep 16, 2020
1 parent 51cbb1e commit ed0dec4
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/autoprefixer-rails/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST autoprefixer-rails-9.8.5.gem 231424 BLAKE2B 94e695613784c954d6402b144edd08dfbec0018a02ffafe2c2e6deecc010c2193137e8ea97f00bbac35881eaf4129403cef9db78736f9618f76bcfd8df5e0598 SHA512 5ef382ba88b1adeb51b41e818bcc3364740809f3576db5228a73eca83829248a618c2e886f68c057d46a68861b6f1ef408f12ec6597f272533c8797273d2e324
DIST autoprefixer-rails-9.8.6.3.gem 231936 BLAKE2B 63f201a73ace0d8f328281521137712f21715bba3fd7c8d098fe81b161d00cd215d6cc89ed786bd79689b81e1b20198d594e307794de527c9cfc0fadb50ccc9d SHA512 f00cfe85742202a1f0fbe672c3279adbe7b3f97155a3696ed274c6987d4f3283895a2f75d4ec6b1709861d72277ec3cf9f0608ad568f5c32ac8df693dc105f8a
DIST autoprefixer-rails-9.8.6.5.gem 231936 BLAKE2B 7c702f5484f9aa2318408fb8c5c8866ccf9d3565d3282e43279b9bea875ac3610b26c0ec302b2bed0779dcd46eca12badaa16faba1046585cddcfa3e8b22b51c SHA512 6b7281661fcaf0c17ee258a321f8d18664f2f305172719f76fe1f3ef6b04fa1460c7102946e95153df7ecf5c3ade3bfc8c22d302927f2e2183ef3b0f3ef8d623
37 changes: 37 additions & 0 deletions dev-ruby/autoprefixer-rails/autoprefixer-rails-9.8.6.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby25 ruby26"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.md"

RUBY_FAKEGEM_EXTRAINSTALL="vendor"

inherit ruby-fakegem

DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
HOMEPAGE="https://github.com/ai/autoprefixer-rails"
LICENSE="MIT"

KEYWORDS="~amd64"
SLOT="$(ver_cut 1)"
IUSE=""

ruby_add_rdepend "dev-ruby/execjs:*"

ruby_add_bdepend "test? (
>=dev-ruby/rails-5.0.0
dev-ruby/rake
dev-ruby/rspec-rails
)"

all_ruby_prepare() {
sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
sed -i -e "/Bundler/ s:^:#:" \
-e '/config.sass/ s:^:#:' spec/app/config/application.rb || die
sed -i -e '1igem "tzinfo", "~>1.0"' spec/spec_helper.rb || die
rm -f spec/rails_spec.rb || die
}

0 comments on commit ed0dec4

Please sign in to comment.