Skip to content

Commit

Permalink
dev-ml/extlib: bump to 1.7.0 and switch to github.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
aballier committed Sep 14, 2015
1 parent e0c9bea commit ed7d355
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/extlib/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST extlib-1.5.4.tar.gz 71003 SHA256 df142ba5a04ccbd4b239a124bd0f634989781b4da63e517c05a036fd419cd9cd SHA512 f70ea54c50499dd8be47b1ee001119a6b6b3c8b29995a2bfb93181dc86790727122d330e67147d00d1c8aff02c263dc1ea954ac2f2ad34f76f5e45f5779c2ea7 WHIRLPOOL 499291050623f27e001ef92f9eea94bdaf1abe5fbd91c6bcad445e747e56f670c3250140c24268b08227dace6da99745407b02cbb7f877687b912dc5d85005e6
DIST extlib-1.6.1.tar.gz 72780 SHA256 88d4b3638cb4da4e04d81ba157e7235e744373c5784cf4b906570d07b890aeca SHA512 9473f474bee99248bdc5e3c56741a191a8f0b89dbf750a4d9e92692b7871c997c584a2dc7e57f55b36b5ddcaf7a11d45b490b117ac15806e35813b82b696f541 WHIRLPOOL 0dc27bad6223de1a1d75684f9caba8708e6c6a80f046c4604fe4bd9da5f860b17be180e3a8d0cdc817e1d99fd6c9feec62a2696b5d78e5706e89ea02460d2d40
DIST extlib-1.7.0.tar.gz 83327 SHA256 3c9fd159a4ec401559905f96e578317a4933452ced9a7f3a4f89f9c7130d9a63 SHA512 3f268e22f7f415e81bbc07c28561fc067ca87748fcdcb6515691d1270858f452ec2ba0eb7b80ca29f06b40f01c1e89a6b71380c7d9de37c60d2bb86093cb8be2 WHIRLPOOL e993986e09a39844b828531e3381954582323c6806ddd48b39c56f511e27a9b6d5f3f9605e02b5dc0698041cd909d4450e28780303ca57884a78eebbd5c37f6d
48 changes: 48 additions & 0 deletions dev-ml/extlib/extlib-1.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit findlib eutils

DESCRIPTION="Standard library extensions for O'Caml"
HOMEPAGE="https://github.com/ygrek/ocaml-extlib"
SRC_URI="https://github.com/ygrek/ocaml-extlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1"
DEPEND="
>=dev-lang/ocaml-3.10.2:=[ocamlopt?]
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
"
RDEPEND="${DEPEND}"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc +ocamlopt"
S="${WORKDIR}/ocaml-${P}"

src_compile() {
cd src
emake -j1 all
if use ocamlopt; then
emake opt cmxs
fi

if use doc; then
emake doc
fi
}

src_test() {
emake -j1 test
}

src_install () {
findlib_src_install

# install documentation
dodoc README

if use doc; then
dohtml src/doc/*
fi
}

0 comments on commit ed7d355

Please sign in to comment.