Skip to content

Commit

Permalink
app-arch/xz-utils: Bump to version 5.2.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Lars Wendler committed Dec 30, 2016
1 parent a0afb65 commit edd71d3
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/xz-utils/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST xz-5.2.2.tar.gz 1464228 SHA256 73df4d5d34f0468bd57d09f2d8af363e95ed6cc3a4a86129d2f2c366259902a2 SHA512 8d6249f93c5c43e1c8eeb21f93b22330fd54575e20bbb4af3d06721192d9f0ca3351878964c9640238ac410b7dd9f16329793c7be7355c7ca0db92c6db6ab813 WHIRLPOOL 7707f10908a57b5780cdb9dda6bac2674f4c5e3350660ea61539b4df5ecc7dbeeb03f05a9b32873d28a14343f9c6491d68095769d3b283018e8139a95bf5f369
DIST xz-5.2.3.tar.gz 1490665 SHA256 71928b357d0a09a12a4b4c5fafca8c31c19b0e7d3b8ebb19622e96f26dbf28cb SHA512 a5eb4f707cf31579d166a6f95dbac45cf7ea181036d1632b4f123a4072f502f8d57cd6e7d0588f0bf831a07b8fc4065d26589a25c399b95ddcf5f73435163da6 WHIRLPOOL 1a3f5b5a0018770098c50ba310cac705dcc44bd5bf58079903eb076e26443c1f687f0c75d4a47aa0df279ab44ca36b340e21b73881521c93a9353165d309be9e
74 changes: 74 additions & 0 deletions app-arch/xz-utils/xz-utils-5.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Remember: we cannot leverage autotools in this ebuild in order
# to avoid circular deps with autotools

EAPI=5

inherit eutils multilib toolchain-funcs libtool multilib-minimal

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="http://git.tukaani.org/xz.git"
inherit git-2 autotools
SRC_URI=""
EXTRA_DEPEND="sys-devel/gettext dev-vcs/cvs >=sys-devel/libtool-2" #272880 286068
else
MY_P="${PN/-utils}-${PV/_}"
SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
S=${WORKDIR}/${MY_P}
EXTRA_DEPEND=
fi

DESCRIPTION="utils for managing LZMA compressed files"
HOMEPAGE="http://tukaani.org/xz/"

# See top-level COPYING file as it outlines the various pieces and their licenses.
LICENSE="public-domain LGPL-2.1+ GPL-2+"
SLOT="0"
IUSE="elibc_FreeBSD nls static-libs +threads"

RDEPEND="!<app-arch/lzma-4.63
!app-arch/lzma-utils
!<app-arch/p7zip-4.57"
DEPEND="${RDEPEND}
${EXTRA_DEPEND}"

src_prepare() {
if [[ ${PV} == "9999" ]] ; then
eautopoint
eautoreconf
else
elibtoolize # to allow building shared libs on Solaris/x64
fi
}

multilib_src_configure() {
use elibc_FreeBSD && export ac_cv_header_sha256_h=no #545714
ECONF_SOURCE="${S}" econf \
$(use_enable nls) \
$(use_enable threads) \
$(use_enable static-libs static) \
$(multilib_is_native_abi || echo --disable-{xz,xzdec,lzmadec,lzmainfo,lzma-links,scripts})
}

multilib_src_install() {
default
gen_usr_ldscript -a lzma
}

multilib_src_install_all() {
prune_libtool_files --all
rm "${ED}"/usr/share/doc/xz/COPYING* || die
mv "${ED}"/usr/share/doc/{xz,${PF}} || die
}

pkg_preinst() {
preserve_old_lib /usr/$(get_libdir)/liblzma$(get_libname 0)
}

pkg_postinst() {
preserve_old_lib_notify /usr/$(get_libdir)/liblzma$(get_libname 0)
}

0 comments on commit edd71d3

Please sign in to comment.