Skip to content

Commit

Permalink
app-crypt/ophcrack: Remove deprecated qt4 USE flag
Browse files Browse the repository at this point in the history
Remove qt4 USE flag, drop old versions, bump to 3.7.0 and fix whitespace
issues as mentioned in bug 644410.

Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Mike Auty committed Jan 18, 2018
1 parent c202031 commit ee95681
Show file tree
Hide file tree
Showing 3 changed files with 12 additions and 24 deletions.
2 changes: 1 addition & 1 deletion app-crypt/ophcrack/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
DIST ophcrack-3.4.0.tar.bz2 279806 BLAKE2B 13bed55784aab2cfa4770c7a79077ebc8def314b925895c15c8bf7213ae5455fe392da3fcc7b2ab624cc2a892b8aae50790bde01fe8344e7ff4c4535f9afeb3b SHA512 38c3b41e76be1b2990cbf6a8ddbe776df3d7821696e42939c759d554a7a52d40555f7e1c8f11e3ab7dc20b553f43d814e271d7519a3b4bb4f84b70468c123df0
DIST ophcrack-3.6.0.tar.bz2 288830 BLAKE2B bc2782d08cb84df24b745fdf0e9723e058da614b73a8d25dfe77cfa2ce291eaf8abd83006a9a410f80bdd240eb81fc402d6d5ebd1c9b92b5a7f1785a203c0c7a SHA512 caa9090b622acac1114f5635c2c58a2c32453ae21a96fc4f424cbc197b056872c282cf9d41142e316a1ffbc9523832b8bc7355c1503c15ac8579470de407a5c9
DIST ophcrack-3.7.0.tar.bz2 294045 BLAKE2B f506d29b27b4b90eadfd4d650512aea54db4228c4c63b90827a7957b544ab59dae757fc521fe62ab3be55d97e483ddde2aea9ad08c96b77d156e863a61f26312 SHA512 27e73979ca3d733629b9b34c490488cc27140efb8b90d266f270c0b95572cf40319a3fb658c02448fc7a3b825cf05c18a69f5d91bd0656d8410a30645f8dc8c6
16 changes: 5 additions & 11 deletions app-crypt/ophcrack/ophcrack-3.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
Expand All @@ -15,11 +15,10 @@ IUSE="debug libressl qt4 +tables"

CDEPEND="!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
net-libs/netwib
qt4? ( dev-qt/qtgui:4 )"
net-libs/netwib"
DEPEND="app-arch/unzip
virtual/pkgconfig
${CDEPEND}"
virtual/pkgconfig
${CDEPEND}"
RDEPEND="tables? ( app-crypt/ophcrack-tables )
${CDEPEND}"

Expand All @@ -29,16 +28,11 @@ src_configure() {

local myconf

myconf="$(use_enable qt4 gui)"
myconf="${myconf} $(use_enable debug)"
myconf="${myconf} $(use_enable debug) --disable-gui"

econf ${myconf} || die "Failed to compile"
}

src_install() {
emake install DESTDIR="${D}" || die "Installation failed."

cd "${S}"
newicon src/gui/pixmaps/os.xpm ophcrack.xpm
make_desktop_entry "${PN}" OphCrack ophcrack
}
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
EAPI="6"
inherit eutils

DESCRIPTION="A time-memory-trade-off-cracker"
Expand All @@ -15,28 +15,22 @@ IUSE="debug libressl qt4 +tables"

CDEPEND="!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
net-libs/netwib
qt4? ( dev-qt/qtgui:4 )"
net-libs/netwib"
DEPEND="app-arch/unzip
virtual/pkgconfig
${CDEPEND}"
virtual/pkgconfig
${CDEPEND}"
RDEPEND="tables? ( app-crypt/ophcrack-tables )
${CDEPEND}"

src_configure() {

local myconf

myconf="$(use_enable qt4 gui)"
myconf="${myconf} $(use_enable debug)"
myconf="${myconf} $(use_enable debug) --disable-gui"

econf ${myconf} || die "Failed to compile"
}

src_install() {
emake install DESTDIR="${D}" || die "Installation failed."

cd "${S}"
newicon src/gui/pixmaps/os.xpm ophcrack.xpm
make_desktop_entry "${PN}" OphCrack ophcrack
}

0 comments on commit ee95681

Please sign in to comment.