Skip to content

Commit

Permalink
dev-lang/tcl: Version 8.6.8.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.44, Repoman-2.3.10
  • Loading branch information
Jeroen Roovers committed Jul 30, 2018
1 parent fa8b338 commit eedb960
Show file tree
Hide file tree
Showing 4 changed files with 157 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/tcl/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST tcl-core8.6.5-src.tar.gz 5846556 BLAKE2B 9c3c48acffc13be526b507fc19711b21e710a84642d37d494bb46a2d4ac9445a95749fd9556ffbda57d55f90bd566d0c9cd72a800a34f062616aacf57e811aa4 SHA512 b726f7d3193ad92ba64911b8c724d5454c5a93d5f5e95462ec0a6d8ccbbdf20093888f66c83956d7631392ca805c1a80430f102c0a932de3ed55311101e0e09f
DIST tcl-core8.6.6-src.tar.gz 5868427 BLAKE2B 3444d474bfdc4958919dbf75527420614251e3cffb0d18fbbf547ffb83ead544f266b6ea868738ae40e02075cf31be6e753e0f89da02a2a81ededf09fc9dd2e6 SHA512 469a0221ed16569b70986cdde261d0c0df3bf64c493b8d6fc8368eb14597f7c2f6a01f082a1c8f27eb720618956e053cc97fbb9aaf7bb29cc96781cdc8e9518c
DIST tcl-core8.6.7-src.tar.gz 5875027 BLAKE2B bc08e4e6639ba33176c8c1e670b957b8ad62a4790ace4ff8f8dc964f676ca87473c31c28f645d32a8287f844756fa224a077f96f1425f61b9872a4a0ae1429a1 SHA512 95c8c5bcb4fe604a77ca6ba9d49f9e90d156feaa9f3ab97661983f256ab54476b103ec8de01cd47231ed95e6df5e36d60514aed2ba5b8f3619cc5a3698ad3ee5
DIST tcl-core8.6.8-src.tar.gz 5887483 BLAKE2B 2b8428652e451b817fe63a811f910001929cdcbc8a8361cdf4f7df8e13cbf9b18c94a91c22c0f09cc46dc0174a66c44774b485539a8f24c14faee6658547b6b8 SHA512 36e6079b582c205e8c89435b361ef96550541357f473aea2ca4e6f01bd84e50ebd1474a75a1ae90640b9a5b392fb01ddfa71f0fa28e409b3569d88c32b4ddb69
DIST tcl8.5.17-src.tar.gz 4546317 BLAKE2B 27031dd3bd5790d03692e77edf91eb7fae8a40d8d193d8c8ce4e79b21f90e683bfc9d5b71764760223987fb163be844e6096d0aea1058b8ce255731d97e2a0ea SHA512 ad5ddb4cd6378fd6bbea8cd85ceb1cf90392b2e8c49fbfb3e4b35c81d3ae3e3f087697c41fcba8c8e06de1d9e7539397e26d58b864dc01ba65abe4ba4efa9568
11 changes: 11 additions & 0 deletions dev-lang/tcl/files/tcl-8.6.8-conf.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/unix/tcl.m4
+++ b/unix/tcl.m4
@@ -1402,7 +1402,7 @@
# get rid of the warnings.
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"

- SHLIB_LD='${CC} ${CFLAGS} ${LDFLAGS} -shared'
+ SHLIB_LD='${CC} ${CFLAGS} ${LDFLAGS} -shared -fPIC -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
15 changes: 15 additions & 0 deletions dev-lang/tcl/files/tcl-8.6.8-libieee.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
--- a/unix/tcl.m4
+++ b/unix/tcl.m4
@@ -2470,12 +2470,9 @@
#--------------------------------------------------------------------
# On a few very rare systems, all of the libm.a stuff is
# already in libc.a. Set compiler flags accordingly.
- # Also, Linux requires the "ieee" library for math to work
- # right (and it must appear before "-lm").
#--------------------------------------------------------------------

AC_CHECK_FUNC(sin, MATH_LIBS="", MATH_LIBS="-lm")
- AC_CHECK_LIB(ieee, main, [MATH_LIBS="-lieee $MATH_LIBS"])

#--------------------------------------------------------------------
# Interactive UNIX requires -linet instead of -lsocket, plus it
130 changes: 130 additions & 0 deletions dev-lang/tcl/tcl-8.6.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,130 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools eutils flag-o-matic multilib multilib-minimal toolchain-funcs versionator

MY_P="${PN}${PV}"

DESCRIPTION="Tool Command Language"
HOMEPAGE="http://www.tcl.tk/"
SRC_URI="mirror://sourceforge/tcl/${PN}-core${PV}-src.tar.gz"

LICENSE="tcltk"
SLOT="0/8.6"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="debug +threads"

RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"

SPARENT="${WORKDIR}/${MY_P}"
S="${SPARENT}"/unix

PATCHES=(
"${FILESDIR}"/${PN}-8.5.13-multilib.patch
"${FILESDIR}"/${PN}-8.6.8-conf.patch # Bug 125971
"${FILESDIR}"/${PN}-8.6.8-libieee.patch
)

src_prepare() {
find \
"${SPARENT}"/compat/* \
"${SPARENT}"/doc/try.n \
-delete || die

pushd "${SPARENT}" &>/dev/null || die
default
popd &>/dev/null || die

# workaround stack check issues, bug #280934
use hppa && append-cflags "-DTCL_NO_STACK_CHECK=1"

tc-export CC

sed \
-e '/chmod/s:555:755:g' \
-i Makefile.in || die

sed \
-e 's:-O[2s]\?::g' \
-i tcl.m4 || die

mv configure.{in,ac} || die

eautoconf

multilib_copy_sources
}

multilib_src_configure() {
# We went ahead and deleted the whole compat/ subdir which means
# the configure tests to detect broken versions need to pass (else
# we'll fail to build). This comes up when cross-compiling, but
# might as well get a minor configure speed up normally.
export ac_cv_func_memcmp_working="yes"
export tcl_cv_str{str,toul,tod}_unbroken="ok"
export tcl_cv_strtod_buggy="no"

econf \
$(use_enable threads) \
$(use_enable debug symbols)
}

multilib_src_install() {
#short version number
local v1=$(get_version_component_range 1-2)
local mylibdir=$(get_libdir)

S= default
# fix the tclConfig.sh to eliminate refs to the build directory
# and drop unnecessary -L inclusion to default system libdir

sed \
-e "/^TCL_BUILD_LIB_SPEC=/s:-L$(pwd) *::g" \
-e "/^TCL_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
-e "/^TCL_SRC_DIR=/s:${SPARENT}:${EPREFIX}/usr/${mylibdir}/tcl${v1}/include:g" \
-e "/^TCL_BUILD_STUB_LIB_SPEC=/s:-L$(pwd) *::g" \
-e "/^TCL_STUB_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
-e "/^TCL_BUILD_STUB_LIB_PATH=/s:$(pwd):${EPREFIX}/usr/${mylibdir}:g" \
-e "/^TCL_LIB_FILE=/s:'libtcl${v1}..TCL_DBGX..so':\"libtcl${v1}\$\{TCL_DBGX\}.so\":g" \
-i "${ED}"/usr/${mylibdir}/tclConfig.sh || die
if use prefix && [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
sed \
-e "/^TCL_CC_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|g" \
-e "/^TCL_LD_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|" \
-i "${ED}"/usr/${mylibdir}/tclConfig.sh || die
fi

# install private headers
insinto /usr/${mylibdir}/tcl${v1}/include/unix
doins *.h
insinto /usr/${mylibdir}/tcl${v1}/include/generic
doins "${SPARENT}"/generic/*.h
rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/{tcl,tclDecls,tclPlatDecls}.h || die

# install symlink for libraries
dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname)
dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a

if multilib_is_native_abi; then
dosym tclsh${v1} /usr/bin/tclsh
dodoc "${SPARENT}"/{ChangeLog*,README,changes}
fi
}

pkg_postinst() {
for version in ${REPLACING_VERSIONS}; do
if ! version_is_at_least 8.6 ${version}; then
echo
ewarn "You're upgrading from <${P}, you must recompile the other"
ewarn "packages on your system that link with tcl after the upgrade"
ewarn "completes. To perform this action, please run revdep-rebuild"
ewarn "in package app-portage/gentoolkit."
ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
ewarn "upgrade them before this recompilation, too,"
echo
fi
done
}

0 comments on commit eedb960

Please sign in to comment.