forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sci-electronics/xnec2c: Version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <[email protected]>
- Loading branch information
Showing
3 changed files
with
75 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST xnec2c-4.1.1.tar.bz2 947969 BLAKE2B 81794dc557d5cc845043be97e07b628e69dcd26fddb3886d11bf31374eba0187491ad9787187f8f4a19cf04f644288c680d3b8778a7b6e144209951b25bbfbf1 SHA512 3a97521f568d79158d5d224958e4cb3708de8214476ba228f9ce0ac122899eb9b06f596d5b0c43a85a18dbd6d86e0751f1a70128c14dd8972f10deeb5a1db980 | ||
DIST xnec2c-4.2.tar.bz2 939408 BLAKE2B 5fbecf436bfebb6979c12d7f76d708a21d784ee5f4f38c6010c5fd16ebe5324ea5469ea578c4ac7fabc26a82e7ea5d5bf6206be79482a9e454183c7b082a20a8 SHA512 bc0929e3cb01eb355c1eb8615087cc70c4585db75d0e6664237e8e268c5dc2159ec9852d917c9fe6b06a3fa780d7ae0b806c2e5cbf48a60622ee4558d9d82063 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
# Install template files in /usr/share/xnec2c | ||
diff --git a/Makefile.am b/Makefile.am | ||
index 9e8873a..6f6203e 100644 | ||
--- a/Makefile.am | ||
+++ b/Makefile.am | ||
@@ -62,7 +62,7 @@ install-data-local: | ||
$(install_sh_DATA) doc/$(PACKAGE).1.gz $(DESTDIR)$(mandir)/man1/; \ | ||
fi; | ||
if test -d .$(PACKAGE)/; then \ | ||
- $(MKDIR_P) $(DESTDIR)$(datarootdir)/examples/$(PACKAGE)/;\ | ||
- cp -r .$(PACKAGE)/* $(DESTDIR)$(datarootdir)/examples/$(PACKAGE)/; \ | ||
+ $(MKDIR_P) $(DESTDIR)$(datarootdir)/$(PACKAGE)/;\ | ||
+ cp -r .$(PACKAGE)/* $(DESTDIR)$(datarootdir)/$(PACKAGE)/; \ | ||
fi; | ||
|
||
diff --git a/src/main.c b/src/main.c | ||
index 4cb541e..6883ceb 100644 | ||
--- a/src/main.c | ||
+++ b/src/main.c | ||
@@ -88,7 +88,7 @@ main (int argc, char *argv[]) | ||
/* Create file path to xnec2c examples directory */ | ||
exe_path[bytes] = '\0'; | ||
Strlcpy( file_path, exe_path, sizeof(file_path) ); | ||
- Strlcat( file_path, "/share/examples/xnec2c", sizeof(file_path) ); | ||
+ Strlcat( file_path, "/share/xnec2c", sizeof(file_path) ); | ||
fprintf( stderr, "xnec2c: creating xnec2c config directory from: %s\n", file_path ); | ||
|
||
/* Create system command to copy examples/xnec2c to ~/.xnec2c */ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit autotools xdg-utils | ||
|
||
DESCRIPTION="A GTK+ graphical interactive version of nec2c" | ||
HOMEPAGE="https://www.qsl.net/5b4az/pages/nec2.html" | ||
SRC_URI="https://www.qsl.net/5b4az/pkg/nec2/xnec2c/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="doc examples" | ||
|
||
RDEPEND="dev-libs/glib:2 | ||
x11-libs/gtk+:3" | ||
DEPEND="${RDEPEND} | ||
sys-devel/gettext" | ||
|
||
src_prepare() { | ||
eapply_user | ||
eapply "${FILESDIR}/${PN}-template.patch" | ||
eautoreconf | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
docompress -x /usr/share/man | ||
dodoc AUTHORS README doc/*.txt | ||
use doc && dodoc -r doc/*.html doc/images | ||
if use examples ; then | ||
docinto examples | ||
dodoc examples/* | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_icon_cache_update | ||
} |