Skip to content

Commit

Permalink
app-text/pinfo: Add clearfilenameprefix patch by Sophie Hamilton (bug…
Browse files Browse the repository at this point in the history
… #619452).

Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Jeroen Roovers committed May 23, 2017
1 parent 94c123a commit ef605e0
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
10 changes: 10 additions & 0 deletions app-text/pinfo/files/pinfo-0.6.10-clearfilenameprefix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- a/src/filehandling_functions.c
+++ b/src/filehandling_functions.c
@@ -758,6 +758,7 @@
tmpfilename = tmpfilename2; /* later we will refere only to tmp2 */
}

+ clearfilenameprefix();
for (i = -1; i < infopathcount; i++) /* go through all paths */
{
if (i == -1)
57 changes: 57 additions & 0 deletions app-text/pinfo/pinfo-0.6.10-r6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit autotools eutils flag-o-matic

DESCRIPTION="Hypertext info and man viewer based on (n)curses"
HOMEPAGE="http://pinfo.alioth.debian.org/"
SRC_URI="https://alioth.debian.org/frs/download.php/3351/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="nls readline"

RDEPEND="sys-libs/ncurses:0=
sys-libs/readline:0=
nls? ( virtual/libintl )
"

DEPEND="
${RDEPEND}
sys-devel/bison
virtual/pkgconfig
nls? ( sys-devel/gettext )
"
PATCHES=(
"${FILESDIR}"/${PN}-0.6.9-as-needed.patch
"${FILESDIR}"/${PN}-0.6.9-GROFF_NO_SGR.patch
"${FILESDIR}"/${PN}-0.6.9-lzma-xz.patch
"${FILESDIR}"/${PN}-0.6.10-version.patch
"${FILESDIR}"/${PN}-0.6.10-info-suffix.patch
"${FILESDIR}"/${PN}-0.6.10-dir-file.patch
"${FILESDIR}"/${PN}-0.6.10-tinfo.patch
"${FILESDIR}"/${PN}-0.6.10-gettext-0.19.patch
"${FILESDIR}"/${PN}-0.6.10-ncurses-check.patch
"${FILESDIR}"/${PN}-0.6.10-libc-basename.patch
"${FILESDIR}"/${PN}-0.6.10-clearfilenameprefix.patch
)

src_prepare() {
default

eautoreconf

append-cflags -D_BSD_SOURCE -D_DEFAULT_SOURCE # sbrk()
}

src_configure() {
econf \
$(use_with readline) \
$(use_enable nls)
}

src_install() {
emake DESTDIR="${D}" sysconfdir=/etc install
}

0 comments on commit ef605e0

Please sign in to comment.