Skip to content

Commit

Permalink
app-pda/barry: Build with -std=c++11 for libsigc++ compatibility (bug…
Browse files Browse the repository at this point in the history
… #566910).

Package-Manager: portage-2.2.27
  • Loading branch information
dirtyepic committed Feb 16, 2016
1 parent e975919 commit ef9003a
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 2 deletions.
8 changes: 6 additions & 2 deletions app-pda/barry/barry-0.18.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit bash-completion-r1 eutils gnome2-utils udev
inherit bash-completion-r1 eutils flag-o-matic gnome2-utils udev

DESCRIPTION="Sync, backup, program management, and charging for BlackBerry devices"
HOMEPAGE="http://www.netdirect.ca/software/packages/barry/"
Expand Down Expand Up @@ -36,6 +36,10 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog KnownBugs NEWS README TODO )

src_prepare() {
epatch "${FILESDIR}"/${PN}-0.18.4-shared_ptr.patch

append-cxxflags -std=c++11

sed -i -e 's:plugdev:usb:g' "${S}"/udev/99-blackberry-perms.rules || die
sed -i -e '/Icon/s:=.*:=barry:' "${S}"/menu/*.desktop || die
}
Expand Down
25 changes: 25 additions & 0 deletions app-pda/barry/files/barry-0.18.4-shared_ptr.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
With -std=c++-11 shared_ptr is available in the standard library so pulling in
the std::tr1 namespace creates an ambiguous reference. Simple fix is to stop
doing that but isn't backwards compatible. We don't care in Gentoo since we'll
always be building barry with -std=c++11 due to libsigc++ abi compatibility.

--- a/tools/bio.cc
+++ b/tools/bio.cc
@@ -42,7 +42,6 @@
#include "i18n.h"

using namespace std;
-using namespace std::tr1;
using namespace Barry;

// keeping a record of all the -i device / -o device pin numbers, so
--- a/tools/btool.cc
+++ b/tools/btool.cc
@@ -59,7 +59,6 @@
#include "barrygetopt.h"

using namespace std;
-using namespace std::tr1;
using namespace Barry;

std::map<std::string, std::string> SortKeys;

0 comments on commit ef9003a

Please sign in to comment.