Skip to content

Commit

Permalink
app-text/atril: Import 1.10.x from Project:MATE repo
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
NP-Hardass committed Feb 9, 2016
1 parent fe4896d commit efa0384
Show file tree
Hide file tree
Showing 3 changed files with 103 additions and 1 deletion.
1 change: 1 addition & 0 deletions app-text/atril/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST atril-1.10.3.tar.xz 2106560 SHA256 2680279137307fe68500ed5006f70bf73a2dd15536dee0592cb77d031d6e3a90 SHA512 8b083aaced82a10cfd7b0d0e5342b23c99ef868da3b2376b547a252659cbe9e3669344515b98ecee046e3011ee7cd5028154a87bd198c92ba577953483107002 WHIRLPOOL 94b3679cedc9b57e35be963458c0f0d8c0c1865a4021c403cf03943824a278013f1b4feaf14d9cc2903768fc6247bea84e1e028be05c46c53047df37899246da
DIST atril-1.8.0.tar.xz 1572068 SHA256 99f4f1e100a4eec696feabbb56d653addd8dbe851c9748d2e929e158524c2dad SHA512 054c1391ea3de196a240b1d0b6eb7402a1472475979ff9603396df7f47b32ed681855aff37c379c7e02e814209e6511c8e3fcc8c13c12b795ff6fd7a0ecdca56 WHIRLPOOL 40e3700485c5c018e5369e410fc24bc18ede6b0be6624777c2df59fff0389cec4ca4331514c70b7547782cc4afde3d75f706b232a260fff21dd758805153f335
DIST atril-1.8.1.tar.xz 1577776 SHA256 036b6bdf9f9caa7468c0cfb680360420cf8477007a0a04dc3b5c50b163c0333f SHA512 1a4a36135a39d216f1cfe5fb91c9d3c16d11da92fbb6b08c314ee09877c7232022a6653649a109ee7a7838a219015f5caab68b2a210399db96f87e4bae520518 WHIRLPOOL 7134a87e8cb3f490677f95f1b05716a4f14e2f8db2bd72d72e9462b061042d9247aca1340b606654aedded43277539c229999198734c4c614842c1aeb2f94fce
99 changes: 99 additions & 0 deletions app-text/atril/atril-1.10.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

ELTCONF="--portage"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"

inherit autotools gnome2 versionator

MATE_BRANCH="$(get_version_component_range 1-2)"

SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
DESCRIPTION="Atril document viewer for MATE"
HOMEPAGE="http://mate-desktop.org"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="caja dbus debug djvu dvi epub +introspection gnome-keyring +postscript t1lib tiff xps"

RDEPEND=">=app-text/poppler-0.16:0=[cairo]
app-text/rarian:0
dev-libs/atk:0
>=dev-libs/glib-2.36:2
>=dev-libs/libxml2-2.5:2
>=mate-base/mate-desktop-1.10:0
sys-libs/zlib:0
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-2.21.5:2[introspection?]
x11-libs/libICE:0
>=x11-libs/libSM-1:0
x11-libs/libX11:0
>=x11-libs/cairo-1.9.10:0
x11-libs/pango:0
>=x11-themes/mate-icon-theme-1.8:0
caja? ( >=mate-base/caja-1.10:0[introspection?] )
djvu? ( >=app-text/djvu-3.5.17:0 )
dvi? (
virtual/tex-base:0
t1lib? ( >=media-libs/t1lib-5:5 )
)
epub? ( net-libs/webkit-gtk:2 )
gnome-keyring? ( >=app-crypt/libsecret-0.5:0 )
introspection? ( >=dev-libs/gobject-introspection-0.6:0 )
postscript? ( >=app-text/libspectre-0.2:0 )
tiff? ( >=media-libs/tiff-3.6:0 )
xps? ( >=app-text/libgxps-0.2.0:0 )
!!app-text/mate-document-viewer"

DEPEND="${RDEPEND}
app-text/docbook-xml-dtd:4.1.2
app-text/yelp-tools:0
>=app-text/scrollkeeper-dtd-1:1.0
>=dev-util/intltool-0.50.1:*
virtual/pkgconfig:*
sys-devel/gettext:*"

# Tests use dogtail which is not available on Gentoo.
RESTRICT="test"

src_prepare() {
# Fix .desktop categories, upstream bug #666346.
sed -e "s:GTK\;Graphics\;VectorGraphics\;Viewer\;:GTK\;Office\;Viewer\;Graphics\;VectorGraphics;:g" -i data/atril.desktop.in.in || die

# Always autoreconf due to lib path conflict.
eautoreconf

gnome2_src_prepare
}

src_configure() {
# Passing --disable-help would drop offline help, that would be inconsistent
# with helps of the most of GNOME apps that doesn't require network for that.
gnome2_src_configure \
--disable-tests \
--enable-comics \
--enable-pdf \
--enable-pixbuf \
--enable-thumbnailer \
--with-smclient=xsmp \
--with-platform=mate \
--with-gtk=2.0 \
$(use_enable dbus) \
$(use_enable djvu) \
$(use_enable dvi) \
$(use_with gnome-keyring keyring) \
$(use_enable introspection) \
$(use_enable caja) \
$(use_enable postscript ps) \
$(use_enable t1lib) \
$(use_enable tiff) \
$(use_enable xps)
}

DOCS="AUTHORS NEWS README TODO"
4 changes: 3 additions & 1 deletion app-text/atril/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -7,8 +7,10 @@
</maintainer>
<use>
<flag name="caja">Enable property page extension in
<pkg>mate-base/mate-file-manager</pkg></flag>
<pkg>mate-base/caja</pkg></flag>
<flag name="dvi">Enable build-in DVI viewer</flag>
<flag name="epub">Enable build-in DVI viewer using
<pkg>net-libs/webkit-gtk</pkg></flag>
<flag name="t1lib">Enable the Type-1 fonts for the build-in DVI viewer
(<pkg>media-libs/t1lib</pkg>)</flag>
<flag name="xps">Enable XPS viewer using
Expand Down

0 comments on commit efa0384

Please sign in to comment.