Skip to content

Commit

Permalink
games-emulation/snes9x: Bump to version 1.58
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Dec 23, 2018
1 parent cf0a6c9 commit f07e30e
Show file tree
Hide file tree
Showing 3 changed files with 191 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/snes9x/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST snes9x-1.56.tar.gz 2876904 BLAKE2B b58dd5c31627cbb374183adb5fe0328739bbebda8c6907ab7f9153085c45d612e51c91ad3223cc10694c9c36a00f69c303c5865d3b022f2769353884056a91b2 SHA512 b8c9438a451ed9a52a66dc04e2bea841aaa9403a2fd266e7042555f93a159ced76061233220eb6fac0f106cea08835c13ef008b2432f6d658689e0fa8ee563e6
DIST snes9x-1.57.tar.gz 2959157 BLAKE2B 6307976247eb3a3bcb506028d75d9054ea853db5c629870a89832fd93ee2fe256799b9191922c67fcd8ef1ed2344d16326212001661c5038a88f290346b9f35c SHA512 d17ec45eeae8f57c618a51243ac54bc3a2a3f09632e4e50c51781cf8557362dbfa7856d9d4ecdebeea344041c2686e2256f6bcd2dcc71660fcf336cf887dcb1c
DIST snes9x-1.58.tar.gz 2830667 BLAKE2B 66446e56a172b318f7cefecc59d927270377f725df0ca89888e1c50eb3f5475729ffc9da86ead5e50f106ab0781ad644ae3b3ed5719724db9b78b687135ead04 SHA512 51f8e92258db58e55f7b0b6c4537a916358891bb5ee35bd984d1970d2fedbdb2f8b3a4f560e0302d3011e521a1072c8a0d69723e8b151f61d33802c02f392d7d
53 changes: 53 additions & 0 deletions games-emulation/snes9x/files/snes9x-1.58-build-system.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
--- snes9x-1.58/gtk/configure.ac
+++ snes9x-1.58/gtk/configure.ac
@@ -33,8 +33,8 @@
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION([0.19.2])

-snes9xlocaledir='${prefix}/share/locale'
-snes9xdatadir='${prefix}/share/snes9x'
+snes9xlocaledir='$(localedir)'
+snes9xdatadir='$(datadir)/snes9x'

AC_SUBST(snes9xlocaledir)
AC_SUBST(snes9xdatadir)
--- snes9x-1.58/unix/configure.ac
+++ snes9x-1.58/unix/configure.ac
@@ -56,37 +56,6 @@
# *** Execution begins here ***
# *****************************

-# Test what compiler flags we should use.
-
-AC_ARG_ENABLE([debug],
- [AS_HELP_STRING([--enable-debug],
- [leave debug information in the final binary (default: no)])],
- [], [enable_debug="no"])
-
-if test "x$enable_debug" = "xyes"; then
- AC_S9X_COMPILER_FLAG([-g], [g])
- AC_S9X_COMPILER_FLAG([-O0], [o0])
-else
- AC_S9X_COMPILER_FLAG([-O3], [o3], [
- AC_S9X_COMPILER_FLAG([-O2], [o2], [
- AC_S9X_COMPILER_FLAG([-O1], [o1])])])
- AC_S9X_COMPILER_FLAG([-fomit-frame-pointer], [omit_frame_pointer])
-fi
-
-AC_ARG_ENABLE([mtune],
- [AS_HELP_STRING([--enable-mtune],
- [use the specified value for the -mtune/-mcpu flag (default: no)])],
- [], [enable_mtune="no"])
-
-if test "x$enable_mtune" != "xno"; then
- AC_S9X_COMPILER_FLAG([-mtune="$enable_mtune"], [mtune],
- [
- AC_MSG_WARN([-mtune failed, trying -mcpu...])
- AC_S9X_COMPILER_FLAG([-mcpu="$enable_mtune"], [mcpu],
- [AC_MSG_ERROR([Please specify a working value for --enable-mtune.])])
- ])
-fi
-
AC_S9X_COMPILER_FLAG([-fno-exceptions], [no_exceptions])
AC_S9X_COMPILER_FLAG([-fno-rtti], [no_rtti])
AC_S9X_COMPILER_FLAG([-pedantic], [pedantic])
137 changes: 137 additions & 0 deletions games-emulation/snes9x/snes9x-1.58.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,137 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools flag-o-matic gnome2-utils xdg-utils

DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
HOMEPAGE="https://github.com/snes9xgit/snes9x"
SRC_URI="https://github.com/snes9xgit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Snes9x GPL-2 GPL-2+ LGPL-2.1 LGPL-2.1+ ISC MIT ZLIB Info-ZIP"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
IUSE="alsa debug gtk multilib netplay nls opengl oss png pulseaudio portaudio wayland xinerama +xv"
RESTRICT="bindist"

RDEPEND="
sys-libs/zlib:=[minizip]
x11-libs/libX11
x11-libs/libXext
png? ( media-libs/libpng:0= )
gtk? (
dev-libs/glib:2
media-libs/libsdl2[joystick]
>=x11-libs/gtk+-3.22:3[wayland?]
x11-libs/libXrandr
x11-misc/xdg-utils
alsa? ( media-libs/alsa-lib )
opengl? (
media-libs/libepoxy
virtual/opengl
)
portaudio? ( >=media-libs/portaudio-19_pre )
pulseaudio? ( media-sound/pulseaudio )
xv? ( x11-libs/libXv )
wayland? ( dev-libs/wayland )
)
xinerama? ( x11-libs/libXinerama )"
DEPEND="${RDEPEND}
virtual/pkgconfig
x11-base/xorg-proto
nls? ( dev-util/intltool )"

S="${WORKDIR}/${P}/unix"

PATCHES=(
"${FILESDIR}"/${PN}-1.53-cross-compile.patch
"${FILESDIR}"/${PN}-1.58-build-system.patch
)

src_prepare() {
cd "${WORKDIR}"/${P} || die
rm -r unzip || die
default
cd unix || die
eautoreconf
if use gtk; then
cd ../gtk || die
eautoreconf
fi
}

src_configure() {
append-ldflags -Wl,-z,noexecstack

# build breaks when zlib/zip support is disabled
local myeconfargs=(
--enable-gamepad
--enable-gzip
--enable-zip
--with-system-zip
$(use_enable debug debugger)
$(use_enable netplay)
$(use_enable png screenshot)
$(use_enable xinerama)
)
econf "${myeconfargs[@]}"

if use gtk; then
cd ../gtk || die
myeconfargs=(
--with-gtk3
--with-zlib
--with-system-zip
--without-gtk2
$(use_enable nls)
$(use_with opengl)
$(use_with xv)
$(use_with alsa)
$(use_with oss)
$(use_with pulseaudio)
$(use_with portaudio)
$(use_with png screenshot)
$(use_with wayland)
)
econf "${myeconfargs[@]}"
fi
}

src_compile() {
emake
use gtk && emake -C ../gtk
}

src_install() {
dobin ${PN}

dodoc ../docs/{changes,control-inputs,controls,snapshots}.txt
dodoc snes9x.conf.default

if use gtk; then
emake -C ../gtk DESTDIR="${D}" install
dodoc ../gtk/AUTHORS
fi

docinto html
dodoc {.,..}/docs/*.html
}

pkg_preinst() {
use gtk && gnome2_icon_savelist
}

pkg_postinst() {
if use gtk ; then
gnome2_icon_cache_update
xdg_desktop_database_update
fi
}

pkg_postrm() {
if use gtk ; then
gnome2_icon_cache_update
xdg_desktop_database_update
fi
}

0 comments on commit f07e30e

Please sign in to comment.