Skip to content

Commit

Permalink
media-gfx/fontforge: bump to 20200314
Browse files Browse the repository at this point in the history
Thanks to Mike Lothian for the cmake port.

Closes: https://bugs.gentoo.org/714612
Package-Manager: Portage-2.3.96_p4, Repoman-2.3.22_p1
Signed-off-by: Mike Gilbert <[email protected]>
  • Loading branch information
floppym committed Mar 29, 2020
1 parent 3e95e36 commit f102463
Show file tree
Hide file tree
Showing 4 changed files with 144 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/fontforge/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST fontforge-20190317.tar.gz 22762120 BLAKE2B 5cb85d2fb9a2a08fe64548f2667c026e916dd0239d17d8f8d7d2fe8ecb51f2106cf3dc6e6298014c0deadffbfe91925327b483ed4750a171fb621aea8bdee60b SHA512 55f9b0f7cafb1aa5a1461dbf39b52ca6b69a2baa6b761c8c28f86a0bb99e090d9ecc981294f51dadd9297b5ebd3036f01cb4f17b9a97a737eb567b4ae6522f20
DIST fontforge-20190801.tar.gz 20766334 BLAKE2B c3206e77da4a966b9e513c41c90e19522f3d1aad990cd3035d7c8a8cc009239811743c12c02df3b02fd91fa5a7738913dba43df14523a738a2232cd2d1a91700 SHA512 78f3e1e94e38e26dcf52c6a0e038753033dc47052b7492f0ac0aaf1b8962e4e4bbf07c2550ef6014ea7290a6429bf669acb0691735efe0aee368480b4b7e6236
DIST fontforge-20200314.tar.xz 13850076 BLAKE2B 5e6ae3b7940a5b3b08811abdfc9d151f231e6d457b219eb0c666e1b831db815b696f345eda0d4d423b7e340f56fca67205734ae19903b3815381080d34b5e95c SHA512 09f5dc93f87ca63668d72d108690604489d6b3cec7eedff1c07ad6d1ce5eae442ab60e79e71ae8b99e9808f3551011788025a86ffc3a9738518d99761d849975
DIST fontforge-dist-20170731.tar.xz 13985256 BLAKE2B 7bc49a3b7747de419e4fafb445062873cf9bf56aa73fd7499509b787a1c0fd6c47b0b5d7bfeb2a69d9237f9f66f989af968b0d00e9d5e57030906394f042f29c SHA512 26f7a40714460716a24dd0229fdb027f3766bcc48db64b8993436ddcb6277898f9f3b67ad4fc0be515b2b38e01370d1c7d9ee3c6ece1be862b7d8c9882411f11
31 changes: 31 additions & 0 deletions media-gfx/fontforge/files/20200314-tilepath.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
From 43e6087ec9bdbb23b8bb61c07efe6490fab23d73 Mon Sep 17 00:00:00 2001
From: skef <[email protected]>
Date: Thu, 19 Mar 2020 17:16:20 -0700
Subject: [PATCH] Tilepath fix (#4231)

---
fontforgeexe/tilepath.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/fontforgeexe/tilepath.c b/fontforgeexe/tilepath.c
index b329b54098..2575058eb4 100644
--- a/fontforgeexe/tilepath.c
+++ b/fontforgeexe/tilepath.c
@@ -571,7 +571,7 @@ static void AdjustPoint(TD *td,Spline *spline,bigreal t, FitPoint *to) {
} else {
bigreal s=(dy1*dx2/dy2-dx1);
if ( s>-.00001 && s<.00001 ) { /* essentially parallel */
- to->p.x = x1; to->y = y1;
+ to->p.x = x1; to->p.y = y1;
} else {
bigreal t1 = (x1-x2- dx2/dy2*(y1-y2))/s;
to->p.x = x1 + dx1*t1;
@@ -610,7 +610,7 @@ static SplinePoint *TDMakePoint(TD *td,Spline *old,real t) {

AdjustPoint(td,old,t,&fp);
new = chunkalloc(sizeof(SplinePoint));
- new->me.x = tp.p.x; new->me.y = tp.p.y;
+ new->me.x = fp.p.x; new->me.y = fp.p.y;
new->nextcp = new->me;
new->prevcp = new->me;
new->nonextcp = new->noprevcp = true;
111 changes: 111 additions & 0 deletions media-gfx/fontforge/fontforge-20200314.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 2004-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )

inherit python-single-r1 xdg cmake

DESCRIPTION="postscript font editor and converter"
HOMEPAGE="https://fontforge.org/"
SRC_URI="https://github.com/fontforge/fontforge/releases/download/${PV}/fontforge-${PV}.tar.xz"

LICENSE="BSD GPL-3+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc truetype-debugger gif gtk jpeg png +python readline test tiff svg unicode woff2 X"
RESTRICT="!test? ( test )"

REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
test? ( png python )
"

RDEPEND="
dev-libs/glib:2
dev-libs/libltdl:0
dev-libs/libxml2:2=
>=media-libs/freetype-2.3.7:2=
gif? ( media-libs/giflib:0= )
jpeg? ( virtual/jpeg:0 )
png? ( media-libs/libpng:0= )
tiff? ( media-libs/tiff:0= )
truetype-debugger? ( >=media-libs/freetype-2.3.8:2[fontforge,-bindist(-)] )
gtk? ( >=x11-libs/gtk+-3.10:3 )
!gtk? (
X? (
>=x11-libs/cairo-1.6:0=
>=x11-libs/pango-1.10:0=[X]
x11-libs/libX11:0=
x11-libs/libXi:0=
)
)
python? ( ${PYTHON_DEPS} )
readline? ( sys-libs/readline:0= )
unicode? ( media-libs/libuninameslist:0= )
woff2? ( media-libs/woff2:0= )
"
DEPEND="${RDEPEND}
!gtk? ( X? ( x11-base/xorg-proto ) )
"
BDEPEND="
sys-devel/gettext
doc? ( dev-python/sphinx )
python? ( ${PYTHON_DEPS} )
test? ( ${RDEPEND} )
"

PATCHES=(
"${FILESDIR}"/20170731-gethex-unaligned.patch
"${FILESDIR}"/20200314-tilepath.patch
)

pkg_setup() {
:
}

src_configure() {
local mycmakeargs=(
-DENABLE_DOCS=$(usex doc ON OFF)
-DENABLE_LIBGIF=$(usex gif ON OFF)
-DENABLE_LIBJPEG=$(usex jpeg ON OFF)
-DENABLE_LIBPNG=$(usex png ON OFF)
-DENABLE_LIBREADLINE=$(usex readline ON OFF)
-DENABLE_LIBSPIRO=OFF # No package in Gentoo
-DENABLE_LIBTIFF=$(usex tiff ON OFF)
-DENABLE_LIBUNINAMESLIST=$(usex unicode ON OFF)
-DENABLE_MAINTAINER_TOOLS=OFF
-DENABLE_PYTHON_EXTENSION=$(usex python ON OFF)
-DENABLE_PYTHON_SCRIPTING=$(usex python ON OFF)
-DENABLE_TILE_PATH=ON
-DENABLE_WOFF2=$(usex woff2 ON OFF)
)

if use gtk || use X; then
mycmakeargs+=(
-DENABLE_GUI=ON
# Prefer GTK over X11 if both USE flage are enabled
-DENABLE_X11=$(usex gtk OFF ON)
)
else
mycmakeargs+=( -DENABLE_GUI=OFF )
fi

if use python; then
python_setup
mycmakeargs+=( -DPython3_EXECUTABLE="${PYTHON}" )
fi

if use truetype-debugger ; then
mycmakeargs+=( -DENABLE_FREETYPE_DEBUGGER="${EPREFIX}/usr/include/freetype2/internal4fontforge" )
fi

cmake_src_configure
}

src_install() {
cmake_src_install
docompress -x /usr/share/doc/${PF}/html
einstalldocs
find "${ED}" -name '*.la' -type f -delete || die
}
1 change: 1 addition & 0 deletions media-gfx/fontforge/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -17,6 +17,7 @@
</longdescription>
<use>
<flag name="truetype-debugger">Enable truetype debugger in fontforge</flag>
<flag name="woff2">Enable support for WOFF2 format</flag>
</use>
<upstream>
<remote-id type="github">troydhanson/uthash</remote-id>
Expand Down

0 comments on commit f102463

Please sign in to comment.