Skip to content

Commit

Permalink
dev-util/dwdiff: Port to EAPI 7
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/707140
Package-Manager: Portage-3.0.9, Repoman-3.0.1
Signed-off-by: Jakov Smolic <[email protected]>
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
Jakov Smolic authored and SoapGentoo committed Dec 28, 2020
1 parent 7c920a1 commit f108456
Show file tree
Hide file tree
Showing 2 changed files with 9 additions and 22 deletions.
31 changes: 9 additions & 22 deletions dev-util/dwdiff/dwdiff-2.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit eutils toolchain-funcs
inherit toolchain-funcs

DESCRIPTION="diff-like program operating at word level instead of line level"
HOMEPAGE="https://os.ghalkes.nl/dwdiff.html"
Expand All @@ -14,38 +14,25 @@ SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86"
IUSE="nls"

CDEPEND="dev-libs/icu:="

RDEPEND="
${CDEPEND}
dev-libs/icu:=
sys-apps/diffutils"
DEPEND="${RDEPEND}"
BDEPEND="nls? ( sys-devel/gettext )"

DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )"

PATCHES=(
"${FILESDIR}/C99-fix.patch"
)
PATCHES=( "${FILESDIR}"/${P}-C99-fix.patch )

src_prepare() {
default

sed -i \
-e '/INSTALL/s:COPYING::' \
Makefile.in || die
sed -i -e '/INSTALL/s:COPYING::' Makefile.in || die
}

src_configure() {
./configure \
--prefix=/usr \
$(use_with nls gettext) || die "./configure error"
--prefix="${EPREFIX}"/usr \
$(use_with nls gettext) || die
}

src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}

src_install() {
emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
}
File renamed without changes.

0 comments on commit f108456

Please sign in to comment.