Skip to content

Commit

Permalink
app-misc/tmux: clean up dependencies and improve overall ebuild's qua…
Browse files Browse the repository at this point in the history
…lity.

Package-Manager: Portage-2.3.5, Repoman-2.3.1
Closes: gentoo#4927
  • Loading branch information
monsieurp committed Jun 14, 2017
1 parent 6852659 commit f10ca95
Showing 1 changed file with 91 additions and 0 deletions.
91 changes: 91 additions & 0 deletions app-misc/tmux/tmux-2.5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools flag-o-matic versionator

DESCRIPTION="Terminal multiplexer"
HOMEPAGE="http://tmux.github.io/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV/_*}/${P/_/-}.tar.gz"

LICENSE="ISC"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="debug selinux utempter vim-syntax kernel_FreeBSD kernel_linux"

CDEPEND="
dev-libs/libevent:0=
sys-libs/ncurses:0=
utempter? (
kernel_linux? ( sys-libs/libutempter )
kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
)"

DEPEND="
${CDEPEND}
virtual/pkgconfig"

RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-screen )
vim-syntax? (
|| (
app-editors/vim
app-editors/gvim
)
)"

DOCS=( CHANGES FAQ README TODO example_tmux.conf )

PATCHES=(
# usptream fixes (can be removed with next version bump)
"${FILESDIR}/${PN}-2.4-flags.patch"
)

S="${WORKDIR}/${P/_/-}"

src_prepare() {
# bug 438558
# 1.7 segfaults when entering copy mode if compiled with -Os
replace-flags -Os -O2

# regenerate aclocal.m4 to support earlier automake versions
rm -v aclocal.m4 || die

default
eautoreconf
}

src_configure() {
local myeconfargs=(
--sysconfdir="${EPREFIX}"/etc
$(use_enable debug)
$(use_enable utempter)
)

econf "${myeconfargs[@]}"
}

src_install() {
default

if use vim-syntax; then
insinto /usr/share/vim/vimfiles/ftdetect
doins "${FILESDIR}"/tmux.vim
fi
}

pkg_postinst() {
if ! version_is_at_least 1.9a ${REPLACING_VERSIONS:-1.9a}; then
echo
ewarn "Some configuration options changed in this release."
ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
ewarn
ewarn "WARNING: After updating to ${P} you will _not_ be able to connect to any"
ewarn "older, running tmux server instances. You'll have to use an existing client to"
ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
ewarn "to temporarily downgrade to access them."
echo
fi
}

0 comments on commit f10ca95

Please sign in to comment.