Skip to content

Commit

Permalink
app-benchmarks/iozone: Bump, #562790
Browse files Browse the repository at this point in the history
  • Loading branch information
patricklauer committed Dec 21, 2015
1 parent b218b30 commit f1b98ec
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-benchmarks/iozone/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST iozone3_397.tar 1679360 SHA256 213d8dcc6f70ca93a903b5fbb92cf758fd25617db4c65d188d29594f12b30d30 SHA512 e154b56735c922173e7cf23344fa0a478982d202b3b831fd605481f69a77295281be121aa57a0164dc12edf5975f231339f6516da5c40906586d48ebacec7c23 WHIRLPOOL 3c041e9c0b094b0e995341d11ef1da746faa0c0dcf615905d16cead7dd9ab84d5d6d301a70358d3a64ceac80a1331054ad31ca6771dd68e5135e7a92f7662d9c
DIST iozone3_408.tar 1822720 SHA256 2112f8a125df8c627760ee2d6d2bd68617ca18e5a312da74175747f225b3fdf5 SHA512 ebc808468c741fff8d7909abd7eb41303c2a68c21ed7754e12bb6f859a88a9f9d040e0cdde42cb320958fbd453ba6014ba46fb7cfb200155f55a6fa7803f5d44 WHIRLPOOL 670a725e68f64f4029a5168839007af35d874b027e770e2cb1b20487a34be2f283b1a4371784b6108beab75952b55684600d146157ec0421e5540def654d9935
DIST iozone3_430.tar 1832960 SHA256 e8388238326dc29359e5cb9f790d193f1e1bdadfbf260e010c50fa682387faed SHA512 f513c1a34bcdfadca0d01a942d55c7494e5646cf17384140df42643259456d41e40a54453ab3b9a1f1ebdeb456a9b4b1f836f979927cac57391b9a20ecdbcb55 WHIRLPOOL bf8074ddfdf63879a84176d5cde3fb00f2fa5f84d7adfce777b8ffa53fa33c97bff7ad37aec45e8271b9cbf723e57fbb0704720ee6d06193deee96ca841b9203
73 changes: 73 additions & 0 deletions app-benchmarks/iozone/iozone-3.430.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

# TODO
# -> linux-arm (32bit) <-
# -> linux-AMD64 (64bit) <-
# -> linux-ia64 (64bit) <-
# -> linux-powerpc (32bit) <-
# -> linux-powerpc64 (64bit) <-
# -> linux-S390 (32bit) <-
# -> linux-S390X (64bit) <-
#
# -> freebsd (32bit) <-
# -> macosx (32bit) <-
# -> netbsd (32bit) <-
# -> openbsd (32bit) <-
# -> openbsd-threads (32bit) <-
#
# ~ia64 ~s390 alpha(?) x86-fbsd

inherit eutils toolchain-funcs

DESCRIPTION="Filesystem benchmarking program"
HOMEPAGE="http://www.iozone.org/"
SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"

LICENSE="freedist"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""

S=${WORKDIR}/${PN}${PV/./_}

src_compile() {
cd src/current

# Options FIX
sed -i -e "s:CC =.*:CC =$(tc-getCC):g" \
-e "s:-O3:${CFLAGS}:g" makefile

case ${ARCH} in
x86|alpha) PLATFORM="linux";;
arm) PLATFORM="linux-arm";;
ppc) PLATFORM="linux-powerpc";;
ppc64) PLATFORM="linux-powerpc64";;
amd64) PLATFORM="linux-AMD64";;
ia64) PLATFORM="linux-ia64";;
s390) PLATFORM="linux-S390";;
x86-fbsd) PLATFORM="freebsd";;
*) PLATFORM="linux-${ARCH}";;
esac

emake ${PLATFORM} || die "Compile failed"
}

src_install() {
dosbin src/current/iozone
dosbin src/current/fileop
dodoc docs/I*
dodoc docs/Run_rules.doc
dodoc src/current/Changes.txt
doman docs/iozone.1

insinto /usr/share/doc/${PF}
cd src/current
doins Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
}

src_test() {
cd "${T}"
"${S}"/src/current/iozone testfile || die "self test failed"
}

0 comments on commit f1b98ec

Please sign in to comment.