Skip to content

Commit

Permalink
app-vim/pydiction: Add ebuild to the tree.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
monsieurp committed May 12, 2016
1 parent d968ddb commit f25308c
Show file tree
Hide file tree
Showing 3 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-vim/pydiction/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST pydiction-1.2.3.zip 476599 SHA256 0998a06be1741edfb1261944ede6fbad77c3742d8924b57ec3ec80908a22b522 SHA512 20e553cb8fdc541e619936f80d8e808484e265d96d1223a7558770e453ad186d5d0057a8b25cd5707bf80b56e40c885097e4195fd66fea2afd8b6d83f84d9441 WHIRLPOOL b1fab3728637dd2ec780f6174790315b478b37eda8000a22891e75cd8a7e04b8f4255cee8ae9e249c18cf03a7beac7f8e650eed40fe345a68d59e2294435b1e2
12 changes: 12 additions & 0 deletions app-vim/pydiction/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Patrice Clement</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Vim Project</name>
</maintainer>
</pkgmetadata>
22 changes: 22 additions & 0 deletions app-vim/pydiction/pydiction-1.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit vim-plugin

DESCRIPTION="vim plugin: Tab-complete your Python code"
HOMEPAGE="https://rkulla.github.io/pydiction/"
SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
LICENSE="vim"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
S="${WORKDIR}/${PN}"

src_install() {
insinto "/usr/share/${PN}"
local pyfiles=( complete-dict pydiction.py )
doins "${pyfiles[@]}"
rm -v "${pyfiles[@]}" || die
vim-plugin_src_install
}

0 comments on commit f25308c

Please sign in to comment.